Fitbit Aria 2 weight Scale and Withings scale not syncing

+1
Syncing between Withings scale and Zwift is KO since a few weeks.
Works only once when you establish the connection between Zwift and Withings.
Can someone from Zwift deal with this issue and tell when it’s gonna be fixed ?

1 Like

+1
Reported to Withings as well, Strava and others. For what it’s worth, Training Peaks works well and quick. Withings recently changed API and upgraded the OAuth to 2.0. That’s when the issues started. Maybe that’ll be a good start.

2 Likes

I must say I miss the auto update from Withings.

It still woks perfectly with all my other devices, it is only Zwift that don’t get the data.

If you look up a bit you will see Shooj said they are working on it.

3 Likes

Let’s not forget the original poster and his problem with the Fitbit Aria 2 weight scale, not the Withings scale. Although his wife says he will soon need two scales to weigh himself given his high degree of unabridged weekend beer consumption, I suspect he still wants to get his Fitbit Aria 2 problem solved so he does not have to go out and buy a Withings scale just to get this functionality again. Just a little reminder. Cheers!

How about it Zwift? Any update on an ETA for this fix?

Still issue synching with Withings

1 Like

Is there any update on this now it’s been a bug since the last update?

1 Like

@Gordon.S
It’s on our to-do list, but it’s lower on that list because it doesn’t break the game, and those types of bugs get higher priority.;

We ask that you manually adjust your weight in your profile in the meantime. Sorry for the news, but we wanted to let you know why it’s not been done yet.

That’s pretty poor response to a bug that you introduced. It’s not like you rolled out a new feature that was somehow buggy. You actually rolled out and update and broke and existing feature.

In any other software company that change would be backed out or fixed forward not leaving customers waiting 3 months with no eta for what seems like a simple thing to fix if you actually spent some time looking at it.

8 Likes

So yet another feature that no longer works.

Sorry but we all pay to use Zwift it unacceptable that even though you know about this problem you just reply with oh well never mind it doesn’t break the game so we won’t look at it. If you tested your updates properly before rolling them out then there would be fewer game breaking bugs to fix. I bought my scales to keep my weight in game up to date yet more money wasted on Zwift.

4 Likes

I bought a smart scale for the sole purpose of synching my weight to Zwift / zwiftpower. Pretty disappointing response from Zwift - if you’re not going to support this then you should remove the connections to Withings et al

2 Likes

Adding myself here to track the issue. I have the same issue with my Withings scale. I only noticed when I looked at ZP and saw the same weight for 3 weeks in a row. Disconnected and reconnected and got one update and now it’s back to not updating Zwift.

2 Likes

Still don’t work. The work around described above to enter the weight manually is not satisfactory when you can’t enter decimals.

When you break an existing feature in a release that, appearantly, many users use and appreciate, you are supposed to fix it.

5 Likes

Another one having the same issue. Hoping it gets fixed. I’m actively losing weight and expect to continue to do so now that I’m zwifting regularly. Would be awesome if the weight updated automatically from Withings.

2 Likes

Same here … can’t be that complex to fix, surely?

3 Likes

I’ve found the easiest way is to Disconnect and then Connect the connection again. It will update that one time.

@shooj a month later any chance that this 4 month old bug has moved up the priority list and got an eta for fix?

3 Likes

Adding a +1 here. This is a great feature for fair racing - as I know w/kg will always be accurate to a decimal place. I miss this!

2 Likes

There have been a few mentions of decimals when recording weight. You can still enter your weight to the nearest 10th of a pound/kg (e.g. 70.5) if you go to Edit Public Profile at https://my.zwift.com/profile/edit.

But to everyone’s point, it is a big convenience that goes a long way towards ensuring fair play. Any changes to the Withings API should be easily fixed, and if there were none, then the feature broke in a Zwift build and should be even easier to resolve.

1 Like

I just got this response from Zwift:

Hi Adam,

Thanks for getting in touch!

I appreciate your report; this is on our radar and our devs are looking into it. Any news we have will be posted to [this ongoing forum thread] regarding the bug.

In the meantime, if there’s anything else we can help with, please let us know!

Ride On.
Gary D.
Member Experience Agent
Zwift

On Sat, Aug 22, 2020 at 12:29 PM <support@zwift.com> wrote:

On Sat, Aug 22, 2020 at 12:29 PM <amb18@cornell.edu> wrote:
For years I have had my Zwift account linked to a Withings third art platform enabling my smart scale to update my weight in Zwift automatically. However, over the past few months, the functionality appears broken. I have tried unlinking and relinking my Withings account, which results in the weight being properly updated one time only, and then the sync becomes broken again. I NOT having the same issue with Withings synching with any other platforms i.e. TrainingPeaks, IFTTT, etc. A web seach has shown other users having the same issue…

Thanks