First timer rider...today. Advice? :)

Okay, I’ve actually had the trainer for a few months, but after a bit of an odyssey, I think it’s set up and I think I’m going to try it out for the first time today. My understanding is to put the bike in a middle gear, and then let the trainer do some work. New to Zwift. New to trainers. New to indoor cycling. Mostly new to cycling. Looking for any advice or any tips you might have for a new rider. Thanks!

Welcome to the Forums, Matt.
Don’t overthink it, go for a ride, and see how it all feels. There are so many variables of trainer / game device / bike set-up, that it’s impossible to advise you usefully before you’ve had a go.

If you haven’t already, I suggest you check out videos on YouTube and elsewhere that are aimed at first-time users. Zwift has done some, as have others. Katie Kookaburra has released some on YT very recently, which might be helpful.
Enjoy yourself!

1 Like

Trying to ride with my kickr core and my pc. It’s saying there is a blue tooth problem. I don’t think blue tooth is part of my pc. Suggestions?

Seems like my zwift odyssey continues. I need some sort of dongle?

I need to buy and ant + dongle and a usb extension cable to take my first ride?

Seems so. Your KICKR Core needs to be able to communicate wirelessly with your PC using either the Bluetooth or the ANT+ protocols. If your PC does not have a built-in receiver/transmitter for either, a dongle is necessary. At the same time, invest in a good quality USB extension cable so that the dongle, plugged into the extension cable, can be physically placed as close as possible to your KICKR Core. Apparently, this helps many people avoid dropouts that would otherwise occur.
Good luck.

(This is all stuff I’ve picked up from reading others’ entries here on the Forums. Personnally, I have only ever used Zwift with iOS and iPad devices using Bluetooth to communicate with my KICKR.)

2 Likes

… I am never going to get a ride on this trainer.

If anyone has suggestions for dongles for me to go purchase next week, I’d appreciate it. I know nothing about ant + and I just want to go on a ride. Haven’t been on a ride since September.

Thanks.

You can use the Companion app as a bridge for now. Make sure you have mobile data disabled on your phone when you do this, and the phone connected to the same WiFi/network as the PC.

https://support.zwift.com/en_us/using-the-zwift-companion-app-rJ7ayD_ES

2 Likes

Thanks for trying. Have the zwift companion app open. Changes the blue tooth error on my zwift game, but still can’t get it to connect. I don’t have wifi on my pc, it’s directly connected with an ethernet cable, so maybe that’s the problem now. I give. I wanted to get a trainer to ride indoors, and it’s just not working for me. This kickr core has been a colossal failure for me.

You don’t need the PC to be on wi-fi, it just has to be on the same network as the phone (app). You can test this by checking the app changes to the map once it starts talking to the game. I suspect your problem is the Kickr is paired to something, like another app on your phone (Wahoo app?). With Bluetooth this makes it disappear from visibility to anything else including Zwift.

But generally speaking, you need a way for the Kickr to communicate with the Zwift software. You don’t have one at present. It’s not really anyone’s fault, you’re just missing a key component. Like buying a TV and DVD player, but no HDMI cable.

Any chance you have an iPad? When my laptop didn’t work (it’s specs were too low I imagine), I used an iPad (its an iPad pro) and that seems to work fine in terms of connectivity with the kickr core. You should be able to get the PC up and running using the companion app, but, if that doesn’t work, and if you don’t have an iPad then it’s just a temporary problem until you can get a dongle set up with your PC.

Find an inexpensive one on amazon, ANT+ dongle and extension cable bundle, should be no more than $30 or less. Don’t get discouraged!!!

I can’t get my phone to pair with my kickr it seems. I’m going through the companion app, but while my phone sees a cickr core, it won’t connect to it. When I load up zwift, I get a message that flashes up briefly that says something about garmin express. I tried disabling it per the message, but that doesn’t seem to help.

Don’t pair your phone directly to your Kickr, that will make it not visible to Zwift.

1 Like

What do I pair to what to make it so zwift sees my kickr???

1 Like

Nothing. Get Zwift running, and get the Companion app working correctly. If Bluetooth is enabled on the phone, you will be able to pair your devices in Zwift, via the app. You don’t do anything on the phone, the Kickr should just show up in the game to select, on the pairing screen. Follow the instructions on the page I linked to above. Ensure the Kickr isn’t already paired to any other software, like the Wahoo app, or Garmin Express, or your phone directly. If it is, Zwift won’t be able to see it. That’s how Bluetooth works in this context, it’s an exclusive connection.

2 Likes

There may be some info in here.

Just can’t get anything to show up under devices. I don’t know how to see if it’s connected to something else.

Okay. That light information helps. My core seems to do the blinking once a second, which seems to mean it is looking for a connection, and doesn’t have one, so why isn’t my companion app bridging it so that my pc can see it?

1 Like

Matt - I have never used BT on my current Kickr so was keen to see how this all works …

I firstly turned Kickr off, unplugged my Ant+ from PC and restarted Kickr.

Ran Zwift on PC.
Ran Companion App on phone
Phone found Zwift (went into Game screen)
Went to Pairing screen (PC)
Unpaired any Ant+ pairings
On pairing screen went to the COG wheel (upper right) to tell it to use Companion App
Companion App popped up a permissions screens to use Location - agreed
Hit search under Power Source, found my Kickr so clicked and added.
It also come up in Controllable without prompting.

So very much per the instructions Dave mentioned above - the only anomaly I wasnt expecting was the Location permission prompt so that may be blocking you. Are you on Android Companion App or IOS?

1 Like