Firefox is blocking 'join event'

A want to join an event in Zwift Power, but somehow Firefox is blocking when I click on the ‘join event’ button. Reason is because of security of the content. Of course I tried to find a solution in the settings of Firefox, but nothing strange here. Couldn’t find a solution in Google or in this forum. In the past it wasn’t an issue, but since a couple of weeks (?) I can’t join any event. Can somebody help me with this?

Zwift doesn’t use Firefox, it uses the native browser on your computer.

What makes you think it’s Firefox blocking’s it?

Because I got a notification of this, made by Firefox. It says: blocked by content protection, by Firefox.

Are you using the Firefox browser to try to join an event at a “https://zwift.com/events/” web page?
join%20zwift%20event
That seems to work fine with Firefox (current version, 70.0.1).

Ok, so this is about ZwiftPower, not Zwift.

I would suggest updating to the latest version or trying a different browser.

Indeed Zwift Power. I tried a different browser and this seemed to be the solution. Thanks for this. Topic closed.