Finish Line Ride not showing in Academy results

I did the Finish line ride on 21 October, but as of today it is still not showing in my results and I really don’t fancy doing it again?


Has this happened to anyone else?

My last recovery ride is not showing, even though it is on Zwift Power. So it shows my Zwift Academy as 90% completed.

But I’d rather have a recovery ride missing (will just do another one this afternoon), than a finish line ride…that sucks Roger!

Make sure you are choosing recovery ride #2 that takes place on the flatland loop in Yumezi. Looks like you did recovery ride #1 again on tempis fugit.

@Roger_Spence
How are you viewing your Academy results? Try closing/refreshing the browser or closing and restarting the app. Perhaps clear your cache. Some people are saying that results are taking a while to appear, but not more than a day.

@Roule_Thoune

I’ve tried those options. Even turned my phone off and back on. Still nothing.

A ticket has been raised with Zwift, so I’ll see what comes off that

Where do you get that screen with the results on?
I have completed but only see the companion results.

Click on the Zwift academy on the main screen of the companion app. Then on academy road.

Thank you for the reply, however that doesn’t work on my companion app as I have “ completed!” On the academy road section?

Click on Complete >