Error Z117


(Dean Russell) #1

Hi I get Error code Z117 at line 504 in patch.cpp when I try to install Zwift on a new PC.

 

Can you please advise what I’m doing wrong

 

Thanks

 

Dean Russell


(Jason K) #2

I looked up that error code, and it corresponds with being unable to create a Downloads folder. Check to make sure your account has Admin permissions and that you’re not using a computer with a network drive (typically on a work computer) or that’s tied to a file sync service like Dropbox.


(Akin S5peed) #3

I have the same issue and i havent been able to use the program in the last 2days. Mine happens when i try to start the app for a new ride. Error {zwift has encountered an error and will close. If the problem persists, please cont Zwift support with error Z117.’ I have unisitalled and reinstalled, shut down the laptop and rebooted and i get the same error


(Magnus Bexell) #4

I also have the same problem. Have tried to uninstall but same error anyway.


(I Guilor) #5

I have now started getting the same error Z117 any solution out there ?


(A ZigZag) #6

I am a new user, trying to install Zwift for the first time and I am getting this error. Its my home machine with full admin rights. Is all these updates so buggy?


(Alex Gaura) #7

I have full admin rights, as well.  I can’t run Zwift.  It appears that this forum is not a functional place for support.  IS there a number we can call?

 


(Stephane Le Beau 6658) #8

I have the same error also.  Not able to use Zwift.

 


(I Guilor) #9

I still can not get on Zwift.Full Admin . I think the error started after the last windows 10 update. Time to cancel my subscription 


(The Shim) #10

Not working for me. I’m an IT admin on a Windows 10 Pro laptop. The error occurs on initial launch. Help


(Paul Allen) #11

Aaron,

Do you have a VPN running and are you sure you are logged in as a local admin on the computer (part of the local administrators group).

I have had no issues running Zwift on a laptop running Win 10 pro with network drives not attached at home with no VPN running. This is going to come down to some kind of permission issue.

Do you use roaming profiles?


(Paul Allen) #12

Also look through this: https://support.zwift.com/hc/en-us/articles/208657936-I-can-t-install-Zwift-on-my-computer?section=201145295


(Jacqueline Willis PACK) #13

Hi,

I had this issue.  I hadn’t been on in a while, and when I logged on this morning the program just wouldn’t start.  So I uninstalled the app and then reinstalled and then started to get this error on the log in page.

It was because I’d downloaded the zwift startup file into my google drive folder (that would sync to google docs and the like).  Absolutely nothing to do with my permissions or my Admin log on or the network I was on (that just confuses the issue).  I restored my normal computer ‘download’ file, and shifted to all the files to there and it worked fine once I did that. 

Double check your downloads from the internet aren’t being downloaded to a sync file.  I didn’t have to re-download to the non sync folder, I just copied it over to my non-synced ‘download’ folder and started up from there. 

I know of course have the joy of putting all my google docs back into the google doc folder but the program is working as it should now. 

Cheers

Jx


(Per j StrokeRide) #14

Today Windows updated and I got the code Z117.

What can I do to get started again. Is Jx tips with copy sync files what I need to do?

 

Per


(Jeff Gaura) #15

I had the same issue wtih Zwift kicking out that code after windows updates.  I noted that after the latest windows updates, the permissions on the folder that Zwift was using to store files (sudirectory of documents) didn’t have permissions for either me or the administrator to use.  I sent screen shots and made recommendations that whatever API they were using didn’t get the task of assigning permissions correct on that folder.  Instead of "OK, let us rewriet that section of code to include the updates Microsoft has made with security on the creating of files and folders, was sent a document asking if I had done yadayada.  The fix was to uninstall windows updates and leave them off until somone at zwift prioritized this issue and got out of the business of sending out “have you tried yadayada” and fix the code.  


(Croc Croc) #16

I had the same issue with Zwift kicking out that code Z117. By reading through your problems i have just solved mine. In my case Zwift wants to download files and it can’t get the download folder. I tried to go to the download folder myself but i could not go there, so i problem solved that. As soon as i was able to go to windows download folder, i started up Zwift and all worked fine.


(Craig Pearson) #17

Hi. Been using Zwift perfectly for years, see your own records. Yesterday and the day before ZWIFT loaded perfectly. Same laptop. Today(i have missed my ride after waking up early to get ready for this event so am pretty tired and frustrated right now) Zwift not loading and giving me error z117, please advise


(David Earl) #18

Experiencing same problem. Has this been resolved or is there a solution?


(Soeren Bonde (D)) #19

Hi. I discovered the same problem, and found the problem and solution.

The physical path to the download folder did contain a special Danish character. In this case: C:\Users\Søren Bonde\Downloads.

I changed the default location of the folder to: C:\Users\sbonde-test

And that did the trick.

 

You can change the default location by Right clicking the Downloads folder and select Properties and then select the TAB Location.