ERG not working

Hi all!

Just startet using SWIFT and my new TACX Flux 2. Tried using workouts with ERG three times now, and it does not seem to work. The resistance is the same, wether it says 100 or 300 Watts. This makes it impossible to keep the watts, it goes up and down all the time.

ERG mode is ON. FTP is set correct. The trainer is connected via Bluetooth. I`m using Swift on a laptop, and the companion app on a mobile phone. I had the Swift app also on my mobile phone (Android), but I deleted this from my phone. I also connect the TACX to my Garmin watch (to receice cadence reading etc), and My Garmin Watch is connected to Swift on the Laptop (to send my pulse).

Any help is highly appreciated:-)

Is your trainer paired as ‘Controllable’?

1 Like

Thanks for a very fast reply! :slight_smile:

Not sure - How can I find out if it is?

The pairing screen will show you.

1 Like

Thanks! Yes, it is turned on.

Anything else I could try?

On the pairing screen it is possible to do a calibration test. I see that some people says this it not necesarry (and might cause issues) when a calibration has been done on the Tacx. Any taughts?

Yes, don’t use the Zwift calibration. It’s recommended that you always use the manufacturer’s app to do the calibration.

1 Like

Thanks @Steve_Hammatt !

Nobody else had issues with ERG not working? Nothing else I could try?

You mentioned connecting your trainer to your watch. Is that via ANT+ ? You said that you’re using Bluetooth, and BT can only connect to one device at a time. Make sure that your trainer is not paired to any other device using Bluetooth.

So you have both Power and Controllable devices showing up as paired in Zwift’s pairing screen?

My watch (Garmin Fenix 6) is connected both to the trainer (three connection were connected when i searched for cencors) and to Swift (sending pulse). How can I find out wether the trainer uses Ant+ or Bluetooth?

Yes, both Power and Cadence and Controllable shows up as paired in the pairing screen (plus Fenix 6 on the pulse pairing). Would these connection show up if the trainer was connected to other Bluetooth devices?

HI have you calibrated it with the Tacx app and ensured when using bluetooth that the tacx app is disconnected when using zwift and all other devices. I have tacx flux and had same issues and sorted it by disconnecting all other bluetooth devices and deleted tacx app unless updating software and calibrating

Thanks @Paul_Ryan2! I`ll certainly try this. Did the trainer show as connected on the pairing screen when you had the issues?

HI i did show as connected both on app and also the trainer but had same issues initially as you could get no resistance when road tilted upwards the power remained constant

1 Like

Zwift is installed on your laptop.
Make sure your trainer is ONLY connected with your laptop.
Turn of bluetooth from your watch.
You cannot connect the trainer with your laptop and your watch at the same time.

1 Like

Thanks a lot guys - with your help the problem is solved. I removed Tacx from my computer and mobile phone and disconnected the trainer from my watch - so that I was sure Zwift was the only Bluetooth connection. It worked perfectly :slight_smile:

1 Like