ERG Mode Résistance delay

UPDATE:
Greetings, Charly’s post gave me an idea. I just now deleted the knowndevices.xml and prefs.xml files, located in the Documents-Zwift folder.

I started Zwift, paired my current devices (Saris H3, HR Strap, Cadence Sensor), chose ride, and then menu and settings and updated my choices for settings.
I then rode for 10 minutes on the New York world and my Saris H3’s resistance and corresponding power (Watts) responded as expected. I’m very pleased with this result. I do not know if this will address the issues that others in this thread have experienced, but this definitely worked for me.

Ride ON…

Today I experienced this issue for the first time. Some of the power changes was significantly delayed (lost lots of stars), and in addition the actual power recorded was 3-4 watts below the target power at all times. I suspect it must have something to do with way to many Bluetooth devices involved today. I use Wahoo Kickr 5 and IPad Pro. In addition:

  • Apple AirPods
  • Wahoo Tickr heart rate monitor
  • Garmin Fenix that also was connected to Kickr tracking the activity (just in case)
  • I had just before the activity used Zwift on my iPhone to plan what workout to do
  • I had used a Windows 10 PC located in the next room to download custom workouts (zwo-files) from a training service I use (wish this was possible to do on iOS). I logged of my account on the PC, but I guess there is a possibility that the Bluetooth connection to the Kickr was still active
  • In addition my wife was sitting in the next room on home office with numerous Bluetooth devices (she also has a Zwift account on the same iPad using her own sensors)

Half way through the workout I decided to pause the workout, disconnect the power source to the Kickr. Turned off Bluetooth on my phone, remove the AirPods, pair the sensors again and start riding again. After a while ERG was enabled again, and after that point everything was working as expected. So I am not sure whether it is the Kickr or Zwift that gets confused over all these bluetooth connections…

Same issue, on several occasions: ERG resistance noticeably delayed 1-2 minutes from what the screen says. However not every workout.

Googled the problem today to try to find a solution. Inspired by this thread tried to couple my AirPods with my iPhone instead of to my MacBook as I usually do when training. That worked, but may be incidential for what I know.

Setup: MacBook Pro/macOS 10.15.7, Zwift 1.0.58982; Magic keyboard + Magic Mouse 2; Kickr Core

I’m having the same issue.

Kickr Core connected to a HP laptop via bluetooth.

Was doing 45 second efforts at 192% FTP, but zwift didn’t change the resistance immediately after the efforts, so I ended up grinding to a halt then having to wait for ERG mode to disable then re-enable.

Sounds like a small issue, but really messes up a training session and is really demotivating when it’s already a hard session.

would I be better off getting an ANT+ dongle for my laptop?

Seme problem, tried two different workouts but I had to give up both.
PC
Kickr

Update. Unpair, pair, close, restart, logout, login… Nothing changed… I tried on Android smartphone and it works brilliantly!!

Same problem. I believe it has to do with connecting via companion app and running AirPod headphones. Connected my Wahoo Kickr and heart rate monitor through companion app and listened to music while riding and had a huge delay. Turned companion app off and connected trainer and heart rate monitor directly through my Apple TV 4K and ERG mode worked perfectly. From reading the history here it would appear that the companion app has a difficult time if there are other Bluetooth devices connected to your phone outside of your trainer. Hope this works for others.

I appreciated your comment. I am using an Apple TV with the iOS Companion app on a Kinetic T6400 trainer. I am also using a separate cadence sensor. I’m going to try NOT connecting my AirPod Pros until AFTER the workout is running and everything is hopefully operating correctly. Then I’ll connect my AirPods and see if staggering the bluetooth connections helps. I expect there to be some delay when using ERG mode, but 30 secs --> several minutes is crazy unacceptable.

Exact thing has been happening to me. I have the new 2020 model, and latest firmware (dec20 release). Any word?

I was having a similar problem this morning. Started a workout in ERG mode, but ERG was not working. I tried turning ERG off and back on again a few times - didn’t help.

After a few minutes, ERG mode started working as expected. Seems like an odd bug.

Zwift is running on Windows 10 with Zwift Companion ( as Bluetooth conduit) running on an iPhone. Wahoo Kickr SNAP 2018.

It’s the AirPods!!!
I had the same problem. Moved AirPods to iPhone can zwift to iPad and it’s fixed!
Boom.
Thanks guys

I don’t have any AirPods…

Worked for me! When listening to Spotify with AirPods through the iPad that runs Zwift, i experienced 30 to 60 second delay. When i listen to Spotify with airpods through another device (my iPhone) it works. At least for two workouts.

I’m still having this problem. Exactly the same in each of my last three rides. 10 minutes warm-up, then start a workout. ERG mode does not function for about the first minute. Then ERG mode kicks in, power stabilizes, and everything is fine for the rest of the workout.

I don’t have, and never have had, AirPods or any other Bluetooth headphones connected to anything. There’s nothing connected to the computer via Bluetooth. My sensors all go through Zwift Companion.

I’m running Mac OS (tried multiple versions) with a Wahoo Kickr and was experiencing the same issue described by all of you.

I’ve found a solution that seems to work consistently for me!

On the PAIRED DEVICES menu there’s a gear icon on the top right. Click that and you will see an option to connect via “Use Zwift Companion”

It will be greyed out until you login to the Zwift Companion app through your smartphone (iPhone in my case). Once that’s done connect via this option and you should be golden!

When I connect using this method it removes the ERG mode delay completely and my rides are as expected!

Hope this helps some of you!

Cheers

1 Like

Thanks for the tip, I am going to try this later today.

*Edit - I can confirm that using the Zwift Companion via Bluetooth fixed the ERG delay!

I am using Zwift with a Kickr (2020), on latest Windows 10 release, latest Zwift build, with an iPhone 12 Pro running the companion app.