Erg mode problems/Kickr Snap


(Kim Ruble) #1

Just got a kicker snap and am new to Swift and have only done a few rides so far. In every ride I have done, the resistance will become so hard I can’t turn the pedals and then erg mode will disable and it will be fine for a while. I don’t know what is triggering this or what I am doing wrong. I have done a few spindowns on the trainer, but that didn’t seem to fix the problem. Any advice is welcome.


(DB Smith (65+)) #2
  1. Check that Snap firmware is v. 2.0.28 (the latest release).

  2. Perform “Advanced Spindown” using Wahoo Fitness app on iPhone. (Note that Advanced Spindown is not the same as a regular Spindown)

I don’t know whether Wahoo has released an Android version for Advanced Spindown; if not, you have to use the iPhone version.

There may be other solutions for your problem but the above are two places to start looking.

 


(Lindsay) #3

Hey Kim-

It sounds like you’re running into some issues with the ERG mode in workouts! It seems like your problem is mostly stemming from not understanding how ERG mode works. When you are selecting your workout, at the bottom of the menu, there should be a toggle reading ‘Use ERG Mode’. With ERG mode enabled, your Kickr Snap will automatically adjust the resistance of your trainer to help you meet the wattage requirement for the workout interval. If during the interval your power remains too low for the target for 5 seconds, ERG mode disables and the trainer releases the resistance until the beginning of the next interval.

Now to address your problem. If the resistance on your trainer ramps up too hard and ERG is bailing out on you regularly, one of two things is probably wrong. First, you should remember to keep your cadence high - 95 -105 rpm on average, unless specifically instructed otherwise by your workout plan. Keeping a high cadence will help mininmize the impact of higher intervals when the trainer ramps up the resistance. If having a high cadence is not the issue, you may want to check your FTP. This can be found on the Workout menu screen in the lower right corner, and directly impacts how difficult the intervals in a workout are. If you find yourself consistently failing workout intervals, you may want to try lowering your FTP to a more manageable level. 

And finally, if you continue having problems or want to use your gears and cadence to control your output during workouts, you can disable ERG mode complete. Simply deselect it on the Workout menu, and your trainer will give you a base resistance level during your workout, ignoring the gradient of the course. Once in the game, this base level of resistance can be adjusted higher or lower using the - and + keys on your keyboard, or the corresponding buttons on the Action page of the Zwift Mobile Link app.

I hope this helped! Ride on!


(Stephan) #4

Now, 

I’ve got same issues with my KickR.
I have a lot of experiences with it, so I know settings etc are ok.
In normal sim mode everything works great, in workout mode when I for example have to do a 3’ 300w effort the rollers gives me so much resistance I need to shift up all the time to try to get a higher rpm, but of course this doesn’t help because erg just gives more resistance to keep those 300W.
I end up riding a 38x28 gear ratio with a cadence of 69, struggeling to get 70 ??? and eventually stop the workout, frustrated …


(Christophe DE GROM) #5

Yesterday, I had the same problem. I have also experience with workouts in Zwift.

I was at the end of a 1’ effort and suddenly my wahoo Kickr blocked. My cadence decreased from 100 to 40.

 

 


(Terry Patton ) #6

Same problem here (Kickr Snap)… in normal sim mode everything is fine but in workout mode (ERG) the resistance goes so high that I can barely turn the pedals…  Has anyone found a solution?


(Alistair Hastings) #7

I’ve had the same problem.  I emailed support and have an open ticket.  I also attached several log files from workouts with the problem.  I have no heard back since submitting the logs - I’ll reply when I hear back from Swift support.


(John Graham) #8

I had the same problem today. Going into the “settings” menu and turning “Trainer Difficulty” to off seems to have helped. I’m using a Tacx Genius Smart.

 

John


(Justin Griffee) #9

https://support.zwift.com/hc/en-us/community/posts/205018636-Struggling-to-control-resistance-with-Zwift-and-Wahoo-Kickr-snap-trainer

 

this is another conversation that seems to address the same question.


(Brian Farrell) #10

I have the same issue with my Kickr Snap doing a workout in erg mode that  Stephan Tytgadt describes but I can add this additional information:  while doing a workout in erg mode I had at the same time both the Kicker Snap controlling my power output and a Saris Powertap displaying my power output on a Garmin 850.  When more than ~150 W is called for by the workout the Powertap shows my output rising, like from 200W to 300W to 400W while at the same time on the Zwift screen the Kickr Snap is flatlining at ~150W.  Now given that the workout is calling for 300W and the Snap is flatlined  at 150W Zwift continues in vain to increase the torque until I am buried with smoke rising from the tire.

In sim mode the Snap controls the gradient fine but again flatlines the power output at ~150W.  This is not a problem because I can set Zwift to read my power output from Powertap while setting the Snap to be the controller.  This can’t be done in workout erg mode as the Snap has to both read and control the power.  I workaround by turning off erg mode and manually adjusting my output to match the power being called for by the workout.

I ran an ANT+ extension right next to the Snap thinking it was a packet dropping problem but that didn’t help.


(Mark Weiss (AZ)) #11

I encountered similar problems and found a few solutions. First, I needed to reset my FTP value. FTP derived from zPower was an estimate and apparently too high. I lowered FTP to about 1/3 of what it had been and then re-rode the test. The new value results in much more appropriate resistance settings.

Second, once I learned how ERG mode worked, I had a lot fewer problems. The key thing that I learned was to keep pedaling at the same cadence and wait for the Kickr to change resistance. There seems to be about a three second delay between what I see on the screen and the machine responding. This was especially important when moving from a high effort block to a low effort block. If I dropped cadence when I rode through the arch and saw the “reduce effort” message, resistance would go through the roof. If I continue pedaling and wait, resistance will trail off in a few seconds and the workout will continue as expected.

When headed into a higher effort workout block, just keep pedaling at normal workout cadence, a few seconds after passing the arch, resistance will increase and will match your cadence. I find that the system normally keeps me two to three watts under what is being asked for. I can pop up wattage for a few moments, but then resistance goes up and reigns me back in.

I also noted that if I stop pedaling, or slow too much, and get the “ERG mode temporarily disabled”, that means until the end of the workout block. ERG will re-engage as the next block starts.

With some help from tech support, figuring these things out have made me much happier with my Kickr and Zwift.


(Daniel Abbott [Ride3R]) #12

Hi,

I had this issue yesterday when trying Workout Mode with my new Kickr Snap.

Glad to have found this post - I’ll try again and see if I get better results. Great advice from Mark Weiss (PMBC).

My issue is that neither Zwift or Wahoo make any attempt to explain what ERG mode is and how you should use it. If they did, perhaps fewer users would question whether their equipment is working correctly.

Also, it might be worth adding a button to Zwift Mobile to manually disable ERG mode during a workout?


(Mark Weiss (AZ)) #13

ERG mode seems to be somewhat like an exercise bike at a gym, no shifting. In ERG mode there’s almost never a need to shift except when being directed to very low power levels (<50w). In most cases, just keep pedaling and the Kickr will adjust resistance to bring you to the correct wattage within two or three seconds. Just keep your cadence steady. If cadence drops, resistance goes up. If you want resistance to drop, increase cadence by 5 to 10 rpm and the resistance will back off. Shifting to an easier gear ratio generally seems to turn into a rabbit hole.

If you want ERG mode to shut off during a workout, just stop pedaling for a few seconds. After your power output drops to 0, ERG will disengage. It switches back on at the next block though.

The caution that I’ve found concerns moving to a block with much lower expected effort, say from 265w to 85w. If you spin down too rapidly, power drops to 0 and ERG switches off. Drop cadence by 5 to 10 rpm and just wait for Zwift to drop resistance on its own.


(Mark Brixton) #14

Mark - I’m not sure your advice makes sense as the workouts are based off your FTP so reducing it down won’t give you the correct output settings. 

My issue like others, is that the resistance increases to the point where it becomes unusable. This is clearly an issue with erg mode. 


(Mark Weiss (AZ)) #15

If your FTP number was derived from anything other than an FTP test using your current trainer, that FTP number may be too high, leading Zwift to set goals that are too high to use on the current trainer.

As for resistance getting to high, when using ERG mode, Zwift always keep the wattage demand constant. If you maintain steady cadence during a work out block, resistance will remain constant too. Since power is a factor of force (resistance) multiplied by cadence (and a constant), if cadence drops, Zwift will increase resistance. It will take more pedal force to generate 100 watts at 80 rpm than it will to generate 100 watts at 100 rpm. If the workout is demanding a set wattage during an ERG workout block, say 200 watts, and I start to fatigue and my cadence drops, Zwift will try to maintain 200 watts of output from me and my trainer will supply ever greater resistance as my cadence slows. Eventually, even standing on the pedals and pulling on the bars won’t help. Exactly what happens on a steep grade. 


(Mark Brixton) #16

I understand the concept but that’s not what’s happening with my trainer and, from reading some of the other comments, it looks like the same thing is happening to others. 

My FTP is derived from a Zwift ftp test and despite keeping the cadence high the trainer still locks out over the course of an erg interval session. 


(Mark Weiss (AZ)) #17

Yes, that sounds like a different issue than I was having. When I maintained cadence, resistance stayed constant.


(Donna Braswell) #18

Like the Zwift rep said up above, the trick is to keep your cadence high enough to overcome the resistance. I can maintain goal if I can keep mine above about 85. Once the cadence drops, the power continues at the same amount but with the lower cadence, it feels higher. If you can’t meet the ERG mode the KICKR has set for you, drop your FTP level on the page where you are setting up your ride. That allows you to run lower power on ERG mode.


(Mark Brixton) #19

I’ve been training around 75 so I’ll give 85 a go and see if that makes a difference. I’m reluctant to drop my ftp down as I want to train in the correct zone and backing it off is going to negate that. 

 


(Donna Braswell) #20

Even dropping by just 5 watts made a big difference for me. I find that watts on the KICKR are harder than outdoors. So that’s why I don’t feel too bad dropping it just a little. And sometimes I want to do a steady power ride but less than my FTP but using ERG. So that’s also when I drop it down.