Erg Mode option not there

(Grrrr, I just prepared a load of screenshots and tried to attach to this message, but not permitted, I guess I need to write 1000 words for each picture :frowning: )

Just purchased a brand new Kickr Core, but on my Android Zwift app, I don’t see Erg Mode appearing at all, it’s supposed to appear as an option on a Workout, but it’s just not there. It’s also not visible on the toolbar when I start a workout (e.g. start an FTP test)

My pairing looks OK, it shows Kickr Core as the Power Source and Cadence

My Zwift app says Version 1.0.56501

My phone is a Huawei P20 Pro running Android 10.

Seems I didn’t need a 1000 words, but any help appreciated.

Thanks

David

Did you connect the Kickr Core as controllable? It should be either power or cadence, Zwift can’t pair both (only needs power really).

Hi,

I got the Kickr on Monday, for Mon and Tues I did not pair cadence (in error, I thought once the Kickr was paired for Power it would automatically get cadence) today I realised I have to pair for Cadence separately, so I did that. But whether Cadence is paired or not, there is no erg mode.

Not sure what you mean by controllable though?

Today I tried loading Zwift onto an old laptop with an ant dongle, and in fact this worked OK, I get Erg Mode just like I was expecting. But I don’t want the hassle of bringing my laptop up to shed every time, would rather use my Android phone!

David

David, when you get to the pair screen, the bottom right tile should display a ‘controllable’ option. Its not enough to pair the kickr and cadence. I have the kickr core and need to connect all 3 (power/cadence/controllable) for it to fully function. Make sure bluetooth is enabled on your phone as its the only way I can get controllable connected.

Ah…that’s the missing link, thank you very much. Paired the “Controllable” option, as well as Power and Cadence, and Hey Presto, Erg Mode appears.

Many thanks

David