Erg mode not working in workout mode

I’m getting the same drama.
Did you find a fix for this?

There’s no way my wattage is as low as it’s telling me🧐

Same problem for me with a flux s.

It has the latest firmware and I did a calibration run.

When using a macbook pro, erg doesnt get close to the wattage needed.

1 Like

Hi Annette, i have the same issue. ERG mode don’t increase résistance and i spin faster and faster with no effect on the Power. Have you got a solution ?

1 Like

Since the most recent update, ERG mode has not been automatically adjusting the tension to the prescribed wattage. It treats ERG workouts as ‘free ride’ and keeps the watts steady regardless of road gradients or interval power targets and I have to manually adjust the tension via the up/down arrows in the companion app.

Riding an Elite Direto to a Macbook Air via BLE connection.

1 Like

…regardless of road gradients

Workouts (ERG or not) always treat routes as though there is no slope (i.e. do not adjust tension for slopes).

Anyway, we (in our house) have done numerous workouts with ERG mode since the update, and everything has worked perfectly. Neo2T + ATV4k.

I fully understand how ERG mode works…

But when the workout goes from, say, Z1 to Z3, the trainer is supposed to automatically adjust tension until you’re within the wattage range. Since the update, this is not happening. The tension is staying flat, regardless of interval zone, which is similar to how ‘free ride’ mode works.

In speaking with other riders, I am not the only one.

3 Likes

Hi All – same exact issue. Brand new Elite Suito in workout mode. tried ios on BLE, and macbook with ANT+. Basically workout mode is like freeride (the resistance gets harder, but it’s not holding the resistance steady). Had an Elite WheelOn (Qubo Digital B+) trainer for years and never had an issue.

Any ideas would be great. Cannot imagine i got a lemon from Elite if there are this many complaints across multiple trainers.

I rode my brand new TACX 2T yesterday. I updated the software before I rode. First thing I did was the FTP test on Zwift that required ERG. Zwift said ERG was activated, but it wasn’t. First wattage goal on test is 100 watts. I could ride at 50 watts or 300 watts. Not activated. I spent hours on the phone with Garmin. First guy said no one else had this problem and it must be Zwift. Second guy said they had seen this problem many times. He offered to send me a new 2T. In December. I still can’t figure out if the problem is the 2T or the ant+ connection between trainer and Zwift or something else. :cry:

In the workout menu page in Zwift is the circle beside ERG mode clicked? Should have a dot in the middle.

It is clicked and it’s marked as “on” during the workout. I heard back from Elite and they claim it’s their highly precise sensor that is accurate. I tried pushing back that one can feel the resistance is not steady but they weren’t having it. While I appreciated their follow ups and responses not having someone in the US that you can talk to live is a bit frustrating. Considering returning it at this point which Is unfortunate given the value.

Is it a Tacx product or Elite one? Sometimes with Zwift the signal can be affected by errant noise coming from other electronic devices and I read someone on here saying their microwave disrupted their ERG workout. Also, try using your smart trainer software to confirm that ERG mode works at all. Then we can look at other problems.

This is the elite suito. Tried on both BLE and ANT connections.

I totally got you mixed up with the other guy posting about his Neo. Have you tried Elite’s software to see if ERG mode is totally broken or just on Zwift? Perhaps there is a Bluetooth problem in Zwift that I am not aware of but others in a different thread may be?

So I’ve tried both ble and ant. Haven’t tried elites sw since I runny have paid account but I can trial it and potentially also TR.

You shouldn’t have to pay for the software. With the Neo there is the Tacx app that allows you to update the firmware and test whether the device works. I am assuming that Elite has something similar.

Hi, I had the same problem and for me the solution was to shut down everything (including apps, tablet, antenna, ant +, tacx, laptop and restart only swift and my tacx, hoping that helps a few people.

I’ve had the same problem with my Suito after installing the Elite App on my cellphone ( am using PC/ win 10 and ant+ dongle). I tried several things for a week or so before i chanced to uninstall the elite app on my phone. That fixed the problem. My guess would be that the Elite app “stole” the signal instead.

In my case the “Use ERG Mode” in the workout menu was missing also.

My wife has had quite a few problems with the workouts, ERG mode doesn’t seem to engage and even in a low gear it requires 200W+ to spin at 85rpm when the warmup is asking for 85W, so frustrating, I took a video of it and Wahoo are really helpful, my fear is it’s a Zwift problem though.

Today to resolve it I did the same thing as Julien. Close the app on Apple TV, then unplug the Kickr V5, then restart both and the problem seemed to go away (until it comes back next time).

It would be nice if someone from Zwift could come up with a solution to this problem, we all have checked ERG mode button as on and double check by re-cycling on the Zwift companion app but seem to have the same problems.

Have the same issue with Erg that most others seem to have described. Have a 2017 KICKR and use Apple TV 4K and Zwift Companion App. The ERG mode again didn’t work when attempting to do FTP test, or previously some of the workouts if the wattage indicated was too low and then doesn’t shift between intervals.

Has anyone had their issue resolved?

Hi,
I’m zwifting with a Wahoo Kickr V5 and using a Macbook Pro since October.
Since this week the ERG mode does not work reliable anymore.

Anybody solved the ERG issues?