ERG Mode issues w/ Saris H3

Zwift, fix your ■■■■… 120 comment on this thread! This is frustrating we all pay for the service… we should all get a discount for the poor experience!

Please do something !!

1 Like

I sent emails to Zwift and they say they are not aware of this issue… Here is another thread about the same problems… I also gave up and ordered an ANT dongle and will use my lap top…



How can they be not aware @shooj?

Thanks @Jonathan_Brault for the other thread, dif Zwift gave you any ticket number we can follow?

No ticket… I gave them the information but they only replied to me (over 2 months) with only generic stuff. Like Did you close the app, restart ipad…

All -

Thanks for pinging me on this. The specific issues underlying ticket TLSINT-182 was fixed last summer. I was involved in that because I loaned my H3 to our QA team (we’re all working remote).

I mentioned it on other threads - but would like you to look into something that was causing weird ERG behavior and random power drops for me.

In my case - I had Garmin Connect installed on my smartphone, and it was disrupting the power sensor signal to my Windows laptop running Zwift. Once I uninstalled Garmin Connect from my Android phone - zero dropouts and zero ERG flakiness.

I’m specifically talking about this issue when I was paired via Bluetooth LE. With ANT+ I never experienced any problems with my H3.

This isn’t to throw Garmin under the bus - other fitness apps that can pair to your trainer have the potential to do the same. So look into those apps running on 1) the computer you use to Zwift as well as 2) your mobile devices. Zwift’s desktop app can detect Garmin Connect on the same device but it has no way to know what’s running on other devices, does that make sense?

1 Like

@shooj - Thanks for jumping back in. Many of us did see your post. I disabled BT on my mobile device (iPhone X), tried to ride and still had the same problem (H3, Zwift on MacOS Catalina.) So have others who don’t have any Garmin-related apps installed. Many have purchased and switched to using an ANT+ dongle with some success there. @Alexandre_Cote has pointed out problems in the BT code and offered to work with y’all to try and correct. @Jonathan_Brault was told by Zwift there is no problem they are aware of yet 125 posts in this thread alone say otherwise. I’ve been a Zwift user since 2017 on two other trainers prior to the H3. I’ve bought all three based upon the recommendations of @Shane_Miller_GPLama and DC_Rainmaker. The H3 is the only one I’m having issues with. Is this a Zwift problem or a Saris problem? What are the two companies doing to correct the issue?


My wife is using our H3 with Rouvy and she never had an issue

This morning I trained on Zwift using one of the training program. No drop out… But my last 4 events, I had bt dropped.

There is one common data to everyone with a problem, it is H3 and zwift and everyone I see starting to experience this problem at the fall update… I never had an issue before this fall/october update.

Last time it dropped my phone which has Gramin connect, was set to airplane mode, so no data, it was on for the music, no BT from the phone, and there is no Garmin connect on my ipad

If I can add, my friend also bought a Saris H3 at the same time of me, using is Garmin and an older MacBook Pro and doesn’t experience problem.

Can it be related to Bluetooth 4.0 or recent Bluetooth chip on new devices. I’m having the issue on every devices I have (iPad Pro, iPhone 11 Pro, MacBook Pro 2018). They all use the same version of Bluetooth chip.

Maybe I can try with an old Bluetooth dongle and see if I still have the issue.

I had the same setup with Tacx neo 2t earlier this year and had no issue.

I believe the issue is Zwift / Saris H3 related and had nothing with Garmin or any other apps. I tried to disable every other Bluetooth device in my house and still had the issue.

Can you re-open a ticket @shooj? Again, I’m offering my help for free, send me an email and I will help.


I’m gutted that I’ve spent as much money as I have done on both Zwift membership and a saris h3! I never get passed 35mins on a workout and have to restart Zwift to get it to reconnect again!! And the first 30mins of my session the erg is all over the place!!

Hey guys, I checked on Instagram with some pros from the “Team Saris + The Pro’s Closet” Zwift team. They all use Ant+. I bought a cheap Ant+ sensor (Anself) and I continued to have random drop-offs throughout riding. So I took the hit and bought the Saris branded (expensive!) Ant+ sensor with a high quality USB-extension to put it right under the bottom bracket.

Just did a test ride with ERG mode on a custom workout for an hour and so far so good!! I did not delete Garmin Connect or anything else. I only changed my home WIFI so it would not be between channels 9-11.

It is over a year later, and I have a new H3 with this same problem. I’m not happy after finding this thread. I too am finding Saris’ support is not responsive. I think I just solved the issue though, so let me share. I’m running the Saris app on Android, but I’m not using Zwift. I updated the firmware when I got it, and there have been no new updates since then. I calibrated back then too, and it made the trainer less accurate. I just tried Erg mode on the Saris app for the first time, watts were so high I could not pedal at all. I couldn’t even calibrate. Using a game app, watts were so high my cadence was so low it hurt or I couldn’t pedal at all. And I often couldn’t control the resistance in game. Here’s what I just did to solve the problem. During the many months I have had this problem a new Saris app came out. I updated the app. I checked for firmware updates and ran the troubleshooter. Passed same as on the old app. In app Settings, I changed the Erg watts levels by lowering them way down. I then tried to calibrate, and it wasn’t working right. I raised the first level of watts in Erg mode settings higher, and I tried to calibrate again. The watts change didn’t affect anything, but this time calibration was working as expected and was successful. Then I went to use Erg mode again on the app. It worked! Then I tried my game app and 2 rides. They now work too! Ya! Of course, I don’t understand why this fixed it because the in game problem I had only happened on some courses and I could ride the trainer outside a game and not using Erg mode with no problem. The resistance was just too low for me. But I’m happy now.

The Anself one I got off Amazon was a fake. The branding was missing on the stick and box. The box also gave the manufacturer as another company.