ERG mode has disappeared


(Thorkild Nielsen) #1

Hi, we have a Tacx Flux trainer connected with Zwift. I’ve recently noticed that when I do a workout, my ERG mode does not appear as an option on the screen. a) will this affect my resistance when climbing a hill? and

b) how do I get ERG mode to appear again?

I also noticed that in settings the controllable trainer is greyed out. I’m not sure if these 2 issues are connected

Please help

Thanks

Michelle  


(Gerrie Delport) #2

Did you pair it as a Power source and controllable trainer?

 


(Thorkild Nielsen) #3

I first only paired it as a power source then I paired it as both a power source and controllable trainer. In both scenarios the ERG mode does not show


(Gerrie Delport) #4

Do your trainer have the latest firmware.

and do you have the option to pair it as FE-C ?

 


(Abigail Oberg) #5

It looks like the last game update may have removed the option to select ERG mode from the Workout Menu for some members on all computers (PC and Mac) used as a platform for Zwift. We are working on a fix for this issue.

However, if you have a smart trainer paired to the game, ERG mode should automatically be turned on by default when you start your workouts.

You can still toggle ERG mode on or off from the Zwift Action Bar during your rides, or from the Zwift Companion app.

Ride On!


(J. H. Edmund Lee) #6

Ditto on Apple TV 4k, ERG mode option no longer shows on Workout Menu.

Was worried about it, started workout anyhow, and ERG mode was on as verified on Companion app on iOS device, which was still able to turn it on and off.


(Thorkild Nielsen) #7

Hi Gerrie. How or where do I check if my trainer has the latest firmware? Regarding the pairing, the power source pairs as Tacx FE-C 6553 and the controllable trainer pairs as Tacx FE-C6553. These are the only available options.

Hi Abigail, thanks for your comments. I’m not sure where the Swift action bar is but I’ll try figure it out. I don’t use the zwift companion app. Hopefully zwift gets to fix the problem soon then we won’t have to use the ‘work around’ solution. Thanks


(Colleen Kirk) #8

For me ERG mode is on be default on PC with no option to disable it visible,


(Brian Blanton - BCB) #9

Hi all.  I’d like to add that I have the same problem in the last several days.  No ERG mode toggle on a workout screen.  Trainer is still controlled when just riding.  But, even though I see the ERG mode button in the Zwift Action Bar, it has no effect at all. 

My setup is:  Macbook Pro and ANT+ connections, no Zwift Companion app, Wahoo Snap with latest firmware. 

As a slightly independent test, I also have a Cyclops Smart Trainer that I used to use with ERG mode.  It also does not work now in a workout/ERG mode.  

Cheers,

Brian

 


(derk drukker) #10

Hi,

I faced the same problem with the Elite Direto. It was al working fine, but after Zwift software update the ERG option had disappeared from the screen.

Win PC, ANT+

BR,

Derk

 


(Niyi Falade) #11

Same here . … I have a Direto  and after the last update … it disappeared 


(Jeff Ledford WBR (C)) #12

Same  No ERG option that i can find.  And it does not come on by default and the button does not show up on the companion app.


(Sime Zaninovich) #13

The same problem
Wahoo kirck
What can i do?


(Niyi Falade) #14

You can enable ERG on the desktop menu … once the workout starts. And not from companion app


(Brian Blanton - BCB) #15

To follow up on my earlier post, I sent a support request to Zwift, and they replied: 

"It’s been verified that a game bug has been discovered which has removed the option to select ERG mode from the Workout Menu on all PC and Mac platforms.

We’re not collecting any additional information on the bug at this time, but we expect to have a fix in the next game update, which we’re aiming to send out very soon."

For me, at least, ERG mode does not work at all, even when trying to activate it from the Zwift Action Bar, and it is definitely not on by default when starting a workout.  

So it seems like there is a fix in the next update…

Ride on!

Brian

 


(derk drukker) #16

Thanks Brian, so let’s wait for the next update!


(Carlos Bas) #17

Is this issue with ERG mode fixed? I am also not seeing ERG mode. Kicker user here. 


(Vincent W.) #18

Hey Carlos, as Abigail mentioned above the ERG mode button missing from the Workouts/Training menu is a bug that is fixed and should be released in an upcoming update. No ETA on that yet, however there is a workaround!

"If you have a smart trainer paired to the game, ERG mode should automatically be turned on by default when you start your workouts.

You can still toggle ERG mode on or off from the Zwift Action Bar during your rides, or from the Zwift Companion app."

As always, if Zwift is still giving you issues with ERG mode you can open up a support ticket by going to this link here. Can’t wait to see you out there riding with us! 

 


(Kiri Ohlson) #19

I have the same problem when doing a set workout. Erg mode does not appear on the action bar at all and I’ve tried pairing through both the ant stick and bluetooth to my Tacx Flux with no joy. I’ve started a training programme now but it did seem to default to erg mode when I ‘Just Ride’ so the capability is there just not in a workout which is really frustrating when trying to do intervals and change through the gears!! When is the update coming?