End of Ride and Garmin importing


(Max Remele) #1

I have had three rides that haven’t automatically imported into Garmin. Unfortunately, it appears to be a known issue that you can’t manually import rides into Garmin, you always get an error message. (it’s an easy process, it just doesn’t work.)

So I’m trying to troubleshoot why some rides import and some don’t and I think it’s happening at the end of the ride. If I click OK right away it takes me to the save screen. However, if I wait it seems to take me back to my ride where I can see my avatar on the bike. I can and do back out from that and am able to save and it is saved in Zwfit, but again it doesn’t carry over to Garmin. Is anyone else having this issue? I am using an Apple TV.

Also, at the end of the ride the OK button counts down for like 30 seconds. What is it counting down to?

 

Thanks.


(Janice North ZBR) #2

My Zwift rides have also stopped automatically syncing with Garmin connect, I have  tried disabling and reconnecting but has made no difference.  


(Jody Deane) #3

I’m having a similar issue - I completed my first ride yesterday (Feb 12) and saved it (I’m using Apple TV). The ride uploaded to Strava no problem, but not to Garmin Connect. I tried disconnecting and reconnecting both in Zwift and in Garmin, and it still hasn’t uploaded. I use my Garmin for all my tracking, so I’m hesitant to purchase a Zwift membership if I can’t see the activity in the Garmin platform…


(Harold Tamminen biciTO) #4

Until the problem gets fixed, you can export your activity from Strava on your computer as GPX to a folder on your computer and then open Garmin Connect on the computer and Import that file into Garmin. I use this method to get my activities from Tacx TTS to Garmin Connect. However I have never had problems going from Zwift to Strava and Garmin but I have a PC.

Harry

 


(Jody Deane) #5

Thanks Harry - that worked for me (although it seems a bit silly to have to do all that work when it should be automatic!)