Distance shown on group ride seems wrong?

I completed my first group ride today and the results in the companion app show my time as extremely long even though it was around 46 mins. Is this normal for group rides? I see a lot of other people with the same issue. I’ve attached a screenshot for reference

Hi @Chris_Stan
Yup, that sure is goofy-looking! I split this out of the Tour de Zwift 2020 thread because it feels like we might need to address this as its own issue.

If you go back to your Activities overview in Zwift Companion, does it show the correct time of 45 minutes and 55 seconds? If so, you need not worry too much - the correct event time was recorded to our server.

Let me forward this along and find out what’s going on. Please stand by.

1 Like

Hi Chris,

This usually happen when you late join the event, did you late join?

I joined when the popup came up while riding in watopia. But when I was connected to the ride it said “looking for riders” or something similar. It then plopped me mid pack somewhere with a bunch of riders.

This was my first group ride so I wasn’t exactly sure how it would start. As far as I know I didn’t join late but I may have since there was no real start. If this is normal results for late starters then I assume this is the issue.

Thanks for clarifying

1 Like

Hi Chris,

Yes the looking for rider is a sigh that it was a late join. When you were riding in Watopia did the pop up show the ride will start in 5 minuites?

It is best to Join these big events early even if you wait in the pen for 7min. If you wait till the last second your transport to the next world will be slow and you will miss the start.

I hope this makes sense.

Yup, it’s a known issue when you late-join an event.

This bug is being worked on. I will update this thread when it’s fixed.

1 Like

Thank you both for your help!

1 Like

Did you try setting your profile to Imperial? I just checked my profile and it is set to Imperial and yet I still see distances in metric. I set my profile to metric and verified I saw metric and then set it back to Imperial and verified I still see metric.

My profile is set to show distances in Imperial.

Are you referring to the distance shown on the tour de zwift event sign up website? They are only shown in metric for some reason. Last year and most other events usually show both distance in km and miles. The companion app shows them in imperial however.