"difficulty: none" setting doesn't stop fiddling my Kickr's setting


(Lieven ODB) #1

Hi,

I’m using Zwift via Ant+ with difficulty setting set to none so that my iphone with TrainerRoad can control my Kickr in ERG mode. This has worked flawslessly for a very long time (I became level 21 like that). As of today’s (24/02) update, having the difficulty setting set to none doesn’t stop Zwift from putting the Kickr to a (very low) sim-level.

I literally feel the kickr ping-pong every 10 seconds between 40W (from Zwift) and 150W (from TR). I’ve tried all of the following: restarting Zwift, restarting TR, powering off Kickr, …

The moment I shut down Zwift everything works perfect again. It really looks like Zwift’s “none” difficulty setting behaves like “very low” instead of “none”.

Can you please have a look as the current behaviour makes Zwift pointless for most of my trainings.

 

Many thanks,
Lieven


(Lieven ODB) #2

btw, I’m on a Macbook running Windows 7 using an ANT+ dongle.


(Eric Oshlo) #3

Have you tried unpairing (or not pairing) your Kickr in the controllable trainer section of Zwift? It would seem that doing so would keep Zwift from interfering with TrainerRoad control of the Kickr.

You could still leave the Kickr paired as a power meter in Zwift if you do not have a separate external power meter.


(Luke Brown) #4

I had same problem last night as well. Seems that the update is forcing Zwift to take control of the trainer, whereas in the past if you were controlling it using something else then Zwift just seemed to accept that.

As Eric said, that’s the same solution I found. Un-pair as a controllable trainer but leave it paired as a power meter source. Then you can control trainer using something else such as trainer road or Wahoo app.

The real problem is the lack of resistance in Zwift Sim mode on the kickr. I lodged a couple of tickets trying to explain it but never got a good answer. It’s just way too low, I’m spinning out my biggest gear and only putting out 250 watts. This forces me to either use workout mode, or control trainer using something else.

 

 


(Lieven ODB) #5

Eric’s suggestion might indeed do the trick as a workaround, I’ll test tonight. Thanks in advance!

It nevertheless doesn’t change the fact that “difficulty: none” is broken ATM :slight_smile:

Luke, I don’t understand your ‘real problem’. The slider sets the resistance level of your trainer in Zwift. This still works as advertised.

The difference versus last week is that “difficulty none” last week meant “we don’t set anything, please do it yourself”, while now it behaves as “we set the trainer to the lowest resistance level possible”.


(Luke Brown) #6

Sorry maybe I wasn’t clear. My problem is that even with the slider at 100% difficulty, on the flats it’s too easy and I’m spinning up my biggest gear. The only way I can get a sensible resistance is to use another app to control the trainer whilst I’m using Zwift.


(Eric Oshlo) #7

Luke, is the lack of resistance an issue in the “just ride” (no workout mode)? My Kickr works just fine but I do know that Zwift will not control resistance in sim mode if you have any sort of workout, including Free Ride, active. Several folks have encountered that issue.

Lieven, out of curiosity why are you running Zwift on your Macbook under Windows 7 rather than just running the native Mac version of Zwift?


(Lieven ODB) #8

Eric,

I’m on a Macbook running Windows because back in the “earlier” Zwift days (talking about July 2015), the OSX client was a lot buggier than the Windows client, resulting in a lot of ANT+ connection issues which didn’t occur while on Windows, where the connection was 100% reliable on the same hardware. To me, it felt like they were developing windows software that also compiled on OSX, putting the main focus on the windows version.

Since then, I never went back :slight_smile:


(Eric Oshlo) #9

Ah! Interesting. I run the native Mac version on my 2012 Macbook Pro. I used it a few times in early beta in the spring of 2015 when I bought my Kickr but put it all away as soon as I could ride outside here in Colorado. According to my log, I rode Zwift only 6 times between March and early June 2015 and didn’t come back to it until November when forced indoors by weather.

At least since Nov, the Mac version has been fine but maybe I just don’t know any better. I’ve thought about running the Windows version under Parallels, but figured putting it behind an emulator might impair the graphics performance. I may have to give it a try just to see.


(Josh Lewis) #10

Luke, run the setting at the lowest, rather than the highest.  At 100% it’s going to make the flats feel flat and the hills feel steep.  The slider is more a “trainer realism” than “trainer difficulty.”  At the lowest setting, it essentially just makes your trainer act like you are always on a flat road, so your gears will have more effect.

Take going downhill - on 100% the trainer will pretty much have no resistance at all, and you’ll be spinning like mad.  at 0%, the trainer will feel the same going down as it did going up.