Dashboard empty?


(Patrick Peeters) #1

When I login to the Zwift dashboard on https://my.zwift.com/dashboard/dashboard, it only shows my name, the rest of the data is 0 or blank with no rides showing up.

This did work after doing my first ride a few weeks ago, so curious if something has changed? I’ve tried both Chrome (on 3 devices) as well as Safari, all showing the same thing.


(David Sack 50+) #2

Did it eventually show up? Mine was fine this morning.


(Patrick Peeters) #3

Nope, everything still shows up blank or 0. No flag, no activities but when I ride my flag and experience are set correctly.


(Eric C. (Zwift HQ)) #4

Hmm, that’s odd. Can you open up a support ticket with us?


(Patrick Peeters) #5

I opened one 3 days ago (#7708), but haven’t heard anything back other than the automated response. Any idea what it could be?


(Eric C. (Zwift HQ)) #6

We are looking into the issue, Patrick. Thank you for your patience.


(Patrick Peeters) #7

Apologies but I don’t see any other way to ask for a status update - any news on this issue?


(Patrick Peeters) #8

I would appreciate an update, it’s annoying to see an empty dashboard and not be able to download any of my rides.


(Eric C. (Zwift HQ)) #9

Hi Patrick,

It’s still with one of our developers. Apologies for the delay - I asked him again if I could get an update but we currently swamped. We appreciate your patience.


(Eric C. (Zwift HQ)) #10

Currently, your rides are also stored in:

Documents > Zwift > Activities

As .FIT files that you can upload to Strava.


(Patrick Peeters) #11

Nevermind, it’s all good now. Will close the case.