cycleops magnus resistance control no longer works


(Scott Huang) #1

hello,

I started using zwift a couple of months ago and am using a cycleops magnus 09526 254 trainer.  Starting sunday night the resistance control stopped working.  I’m not sure if it’s because I started using an ant+ usb and garmin heart rate strap or what.  I’ve unplugged the ant+ dongle, rebooted my machine and started zwift, but the resistance control still doesn’t work.  -.5% grade feels the same as 4% grade.  I had been using zwift and this trainer for a couple of months without issue. please help!

 

scott


(Scott Huang) #2

by the way, here is my entire setup.

 

I’m running zwift launcher version 1.0.11  1.018779 on a macbook pro

I’m using bluetooth to connect the cycleops magnus trainer to zwift.  the firmware on my cycleops magnus trainer is version 31.  I asked the cycleops guys if that was the latest version of the firmware. 

I’m using GXG-1987 Mini ANT+ USB Dongle Adapter and a garmin heart rate monitor strap.  

As I said earlier, prior to sunday things worked fine. the ANT+ USB Dongle and heart rate strap were added to the mix on sunday and that’s when the problems started.  However, I also saw that you released an update this week so I don’t know what the culprit is.  Please help!  Sunday night I was able to get things working through a series of reboots, restarts, pairing and unpairing.  Tonight I was not able to get things working.  


(Evan LARDINOIS RCC) #3

Hey Scott,

Take a look at this thread. Some other users have had similar issues with varied success. 

https://support.zwift.com/hc/en-us/community/posts/115000396563-Cycleops-Magnus-ANT-Power-Drops

Also, could you re-calibrate your trainer? I did not see it mentioned above but maybe I missed it.

 


(Tyler Shannon) #4

Hi Scott, 

 

This is a potential new bug. I’m opening a ticket so we can work with you more closely. Thank you! 


(Adam Smith Burnsco BSR (ZNZ)) #5

Hi guys,

I have recently started having the same problem as Scott.  I am using the Cycleops Hammer and have everything synced via bluetooth through my MacBook Pro.  

I am running the latest Zwift firmware and also have updated the Hammer firmware to the latest version.  Everything had been working fine but it seems after installing the Zwift update the Hammer will not provide any resistance changes as the course profile varies.  I deleted the Zwift program and reinstalled it, no luck.  

What I did notice was that if I use the Erg mode for a workout it does work.  The blue LED on the Hammer is solid blue in Erg mode showing it is being controlled by the Zwift program.  The LED flashes blue in normal ride mode showing it is not being controlled by the program.

Any help would be greatly appreciated.  

Adam


(Daniel O'Rourke) #6

I’m so glad you started this thread. I’m having the same issue, it started around a week ago now. Going up steep hills is exactly the same as going down steep downhills in terms of resistance. I updated the firmware on the magnus, and deleted and reinstalled the zwift program, but still no luck. I connect to the magnus using bluetooth on a MacBook air and it has been working fine for the last couple of months. I also use a heart rate strap and that has never interfered.

On the plus side, you can now set amazing records going up hills given it acts as if you’re on the flat!

Will lookout for advice on this matter.

Danny


(Kevin Connolly) #7

I’m also having the same problem. I am on CycleOps Hammer and using Zwift version 1.0.18779 for Windows paired using Bluetooth through the Zwift Mobile Link app for Android.

I am able to pair all my sensors and ride without any issues but the resistance just does not adjust when I go up or down any hills. Also noticed same as Adam mentioned above where my LED just flashes blue rather than remain solid.

I last used about a month ago and it was working fine. Though I have updated Zwift to the latest version since I last used it.

I’ve tried restarting my PC, phone and smart trainer etc but no luck.

Any help is appreciated!

 


(Travis Lemmer) #8

All -

I’ve been riding Zwift on my Magnus trainer for several months and it was working great up until 8-12 days ago. Then the resistance stopped varying with incline/declines, just remains constant. Power measurement looks correct. My setup has not changed, using same MacBook machine, network and connection.

Any new thoughts on a resolution?

Thank You,
Travis


(Adam Smith Burnsco BSR (ZNZ)) #9

Hi All,

This is the response I have just received from Saris today after trying various fixes for the past couple of weeks unsuccessfully.

Tyler S. (Zwift)
Jul 24, 12:33 PDT

Hi Adam,

It looks like this is a new bug that is potentially affecting most Saris smart trainers. I’m escalating this to our QA department, who are looking into this currently. Unfortunately, as it appears that the bug is BLE based, the only current workaround is using an ANT+ dongle. However, that is far from ideal.

I’m going to be placing your ticket on hold. As soon as I have an update, I’ll pass it along. I apologize, I know how frustrating this is.

Ride On!


(Tyler Shannon) #10

Hi Adam, 

 

That one is actually from us here, not Saris. 


(Adam Smith Burnsco BSR (ZNZ)) #11

Oops. Apologies Tyler!


(Phil Clarke) #12

This message thread caught my eye.  I’ve been using a Magnus trainer since March.  For what it’s worth, the trainer appears to be working okay. 

Even with various app builds for the iOS and tvOS Zwift over the last few weeks, my trainer resistance seems to be operational over BLE to iPad and AppleTV.

I updated the Magnus trainer firmware (to v31.032) on June 25, and the resistance was working both before and after the update.  

 

phil

 


(Karla Gual 7874) #13

Any update on this issue? I ve been having the same problem for the same amount of time commented in previous comments. Thanks


(Scott Huang) #14

Hey Everyone,

I wanted to update everyone with what I’ve been told.  They say that they’re working on it, but won’t give an ETA for a fix.  They keep trying to get me to use ANT+ instead of bluetooth, but I don’t want to have to buy a USB extension cord (the ANT+ dongle needs to be super close to the trainer for it to work properly).  More recently they asked me to use the Zwift Mobile Link App, which I haven’t tried yet, not sure if that means I’d only be able to look at the small screen.  I’m hoping that the more people make noise about this the more motivated Zwift will be to fix this problem

scott 


(Gerrie Delport) #15

So you don’t want to buy a $3 usb extension cable and you don’t  want to try the Mobile Link app? 

Maybe you could try this to put your log files into https://zwiftalizer.com/ it will show you how bad the dropouts are.

Looking at your older rides it seem like you got a lot of signal dropouts and it look like it got worse over time.

 


(Scott Huang) #16

Gerrie,

 

Your attitude is unnecessary.  My not wanting to buy a USB extension cable has nothing to do with the price.  It’s something that I didn’t need before when the software was working and therefore don’t want to buy.  It’s one less thing to end up in a landfill as far as I’m concerned.  I don’t know if you are a zwift employee or just a troll who just likes to stir up trouble, if you are a zwift employee then you could use some lessons on how and how not to speak to your customers.  If you are just a pathetic troll who likes to butt your nose in other people’s business then learn to read more carefully and piss off. 

 

This is not some freeware application maintained out of the goodness of someone’s heart.  Subscription fees are collected and as a paying customer I have a right to expect a working product, and at the very least to know when the product will be fixed, versus being told over the course of close to 4 weeks now that “we’re looking into it”.    

 

And for the record, you should read my post more carefully.  I did not say I wouldn’t try mobile link, I said I haven’t tried it yet.  Since I hadn’t used it I didn’t know if I was going to be staring at a tiny phone screen as my interface.   

 

Now, for the rest of the folks here who are experiencing the same problem as I am with the cycleops magnus, here’s what the result was when using mobile link and macbook using bluetooth.  

 

Monday 7/31 it worked, meaning the resistance on uphills was harder than on level ground or downhills.  I was just about to respond to this forum and my open ticket with the good news, but thought I should wait until I tried it a few times.  Unfortunately, on Tuesday 8/1 and Thursday 8/3 resistance control didn’t work again.  uphills and downhills felt the same.  One thing that was interesting was on the mobile link interface when I clicked the bluetooth icon, it said no bluetooth devices were paired even though on the zwift application on my macbook it clearly stated I was paired using bluetooth to my trainer for both resistance control and power.  


(Gerrie Delport) #17

I don’t work for Zwift I am just a happy customer trying to help.


(Andy Gooch TT1) #18

I am having the same issue but with a cycleops powersync bluetooth trainer.  2 months ago zwift just stopped recognizing my trainer because of a bug with the zwift mobile link app, and now that they fixed it so my trainer will at least be recognized it will not adjust resistance based on the ride.  Is there any timetable on this being corrected?


(Scott Huang) #19

I got a note from the helpdesk saying that the update on friday the 4th should have fixed the issue.  I have only done one training ride since then and it seems to have worked.  I was waiting to get at least a few more rides in with the resistance control working before saying all looks good.  


(G rumpyPat (A)) #20

Just started having this issue right now. Worked fine in the race I did 2 days ago. Now it’s not. I have a ant stick with USB extension under my down tube. The power drop out issue is bad enough, I got around that with a Stages pm. I think this thing is going back and I’m going to pony up for a Neo.