Cycleops Magnus ANT+ Power Drops


(Steve Rode (QCW)) #1

Started using the  Cycleops Magnus with Zwift a couple weeks ago.  I have issues with the power dropping out, reading zero for 1 or 2 seconds then going back to normal.  I have a Garmin USB ANT+ stick on a 10 foot USB cord from the laptop and the stick is withing a few inches of the Magnus head unit.  I’ve recorded rides on Zwfit then posted to Strava and compared to the data on files from my Garmin 820 and 510 bike computers and the Zwfit files show the power drops, but the Garmin devices do not showing that the Magnus is indeed putting out the ANT+ Signal for power and not dropping out.  This morning I had 1 Garmin about 10 feet from the Magnus and it still didn’t drop power while the Zwift file sent to Strava did.  Obviously a problem when you are doing intervals and Zwfit thinks you have lowered power and tells the Magnus to adjust for more resistance to compensate.  The Magnus has the latest firmware and is calibrated, I think this has to be a Zwift problem.  I never had this issue when using a power tap wheel, Pioneer Powermeter, or Power 2 max power meter though, just now with the Magnus.  Any suggestions?


(Evan LARDINOIS RCC) #2

Hey Steve, 

 

Thanks for your comment. Let me setup a ticket for you. We will need some log files to do so. We will be in touch.

Thanks!

Ride On


(George Squibb) #3

I have a similar problem, except that my Magnus seems to disconnect from Zwift but the power reading stays fixed at whatever it was when the connection broke - I can “coast” forever. Power cycling the Magnus immediately corrects the issue. 

Thanks, George


(George Squibb) #4

There is a firmware update that I just applied. I’ll let you know if it makes a difference. 

 


(Ryan Beaver) #5

How’d the firmware update work? I’m having the same dropping problem. I can barely get them to respond once a day at Cycleops and at this point I had written them off until I read this post. Did it fix it? Is it a Magnus problem or a zwift problem? I’ve even tried recalibrating the trainer to no effect. 


(George Squibb) #6

No change with new firmware. I think it’s a cycleops problem as I get simultaneous drops on Zwift and my Garmin. 


(David Griscom YCW) #7

I’ve had my Magnus for about a month now.  I have not seen the issue Steve has (temporary drop out) but I just recently saw the issue George mentioned where power just stays at a fixed level and does not change no matter what.  The avatar just continues at that pace.  I have not seen this with CVT but that doesn’t prove its not a CycleOps issue.  Cycling power seems to resolve it


(Ryan Beaver) #8

I will post this in the other thread with a similar subject too: Just got done doing the mountain route after making a change(Magnus user here). Before, when I was getting the drops to 0, on the pairing screen I had the “power source” as the Saris PWR and the “controllable trainer” as Saris FE-C. Today I changed the pairing to make them both Saris FE-C(I couldn’t make them both Saris PWR). Mild success! The 0 power drop outs disappeared but were replaced with the situation above where the power just stays at a fixed level for a few seconds. It still sucks but at least I can ride it for now. Also, out of saddle steep grades like heading to the radio tower are impossible. It won’t hold a wattage. Cycleops is sending a dongle for a firmware upgrade but if this doesn’t fix it they’re sending a new resistance unit. If that still doesn’t do it I’m returning the trainer.


(Bill Penney) #9

I’ve had both issues discussed here. I was getting the drops to zero using a 10’ USB extension cable. I ended up replacing the cable with a 6’ cable and my problem went away.

within the past 3 months I’ve had two concurrences where the power stays at a fixed level and have to end my ride. I’ve just recently upgraded to the latest firmware, so I guess time will tell. 

Update: Just had another wattage freeze while doing my workout last night, so it appears the firmware update did not correct this issue. Fortunately resetting the trainer corrected this without having to end my workout.  


(Brian Gruch RO4H /Team ZF) #10

Had the same problem today riding Richmond Hilly during my 3rd ride on a brand new magnus.  Power and resistance hit a point where it stayed fixed.  Seemed like the magnus froze up and kept transmitting constant power and would not adjust resistance.  Cadence and HR worked fine so I know it wasn’t my dongle.  Update: Completed  2 x 90 minute rides with no issues.  I switched my Magnus (Power and controlled trainer) connection to the laptop Bluetooth and left my HR and Cadence on the ANT+ dongle.   


(rob sebastianelli(TeamZF)6303) #11

 I’ve had the same problems with my Magnus where the unit wont hold the wattage or resistance on steep grades. This happens in ZWIFT and on the CVT app.  They have sent me a new resistance unit and it has same problems. 


(Steve Rode (QCW)) #12

I ended up returning my Magnus, the dropouts were corrected using Bluetooth but the power was just not predictable - it would climb during a long steady tempo interval (30 minutes) about 15 watts from start to finish and on hard intervals at the end of a long training session it was just too much to manage and ended up me failing the interval.   Ended up replacing it with an Elite Drivo which has none of these issues although the power seems to wobble a little on steady intervals, but the average is spot on the requested setting and matches my crank power meter within 1 or 2 watts.   The Magnus is great for the Zwift experience, lots of fun - it just didn’t produce consistent enough results for long structured training for my. 


(Rodrigo Bórquez) #13

A couple of weeks ago I started experiencing the same problem: Power drop to zero.
Only solution is to restart the Magnus every time during my workout (the power doesn’t come back alone after a couple of seconds), what is in fact very annoying when you are focused in your training.
Beggining of the year I didn’t have any of these issues and I always kept the same configuration: MacBook with Garmin ANT+ receiver 5ft from the Magnus.
Does somebody have a solution for this?


(George Squibb) #14

Mine has been fine for quite a while. Make sure you update firmware with the PowerTap app. Also try to eliminate interference from other electronic devices. I think my drops may have been caused by sending music from my iPad to my sound system via Bluetooth. 

-George 


(Ralph Smith) #15

I have owned a Magnus for over a year. Started off with using Bluetooth interface with Mac and had the constant power problem often enough I was going to return it.  Switched to WINDOZ PC with ANT+ problem reduced but still occurred. Turning off Bluetooth on any device near the Magnus seems to make the problem go away.  About a week a go I had the problem again - my wife left her iPad in the room with Bluetooth turned on. Maybe just a coincidence?


(Anthony James (Team Extreme)) #16

I am curious as to what the actual solution is or was?  I have read through this thread and another and I am not seeing a clear answer as to how to solve this.  Can anyone from Zwift team share?

 

Thanks

 


(David Griscom YCW) #17

Anthony, it is yet to be fully solved.  CycleOps has acknowledged that this is their issue.  They came out with a firmware update a couple of weeks ago to address it.  Many people reported it made things worse.  They have since removed that “fix” from their website and are supposedly working on a new fix


(Anthony James (Team Extreme)) #18

David,

Thanks for the update.  I am trying to help a young kid I am coaching and his power stays static and I and he have been boggled with how difficult it is to get this working.

 


(Trey Jordan) #19

I went months without this problem, but now it happens every ride.  It typically happens 5-6 times per hour for 2-5 seconds each time. I don’t participate in any races due to this issue.


(Rodrigo Bórquez) #20

Exactly the same is happening to me! Months without the issue and suddenly it came back.