CycleOps Hammer


(Caiman Lieu) #1

I have been using my Hammer for about a week now, and it seems to be working okay so far. I am also using a KICKR2 so I have something to compare this Hammer to. The 20 lb flywheel of the Hammer seems a little smoother but it is certainly not much different than the KICRK2 with a 12.5 lb flywheel, as I was expecting a substantial difference.

Nonetheless, the reason I am here is because the resistance of my Hammer seems to lag behind a climb. It is really bad to climb up the escalator with the London route. The resistance basically kicks in late but then it also releases late on top of the climb. Also, the 15% resistance seems much harder with the Hammer vs. the KICKR2. With the KICKR2, I have been able to grind up to the last section of the top of Zwift mountain at around 5-7mph with Trainer Difficulty set to 100%. With the Hammer, I get stalled immediately when I hit the last steep section of the climb as I can barely turn the cranks. Does anyone have any of these problems? Thanks!


(Paul Fish) #2

So, I too have this same problem in exactly the same place. I thought at first it was some kind of lag on my internet connection. It is possible that there is some kind of issue with the trainer itself, but thus far I am placing more of the problem with Zwift. The possibility of lagging interaction between the program and the trainer is something I have read about.  I’ve seen this with lesser climbs where there is a sudden increase in the gradient. 

 A day a ago I tried this experiment. Just before I hit the escalator climb I attacked, ramping my power up above 500 watts and my avatar still stopped halfway up the 15% climb all while I was still belting out the power. Then I had to “grind” up the rest of the climb really slow, all while others were flying by me. Of course, it is a little disturbing, but it is still a heck of a workout. Hope someone at Zwift will look in to it and make it a little better.


(Caiman Lieu) #3

This is a problem with the trainer, not Zwift, as I also have a Kickr2 and do not have this problem. It might be that Zwift will need to customize a resistance profile specifically for the Hammer but who knows. My theory is that Hammer has a slow on-board processor so it can’t keep up with the command. This resistance lag is there the whole time for the Hammer but it just becomes obvious at the escalator because it is so short and steep, the trainer just cannot response fast enough. With a longer climb, it would have more time to respond so the lag is not too obvious but the problem is still there nonetheless.


(Paul Fish) #4

There is a thread from DC Rainmaker that seems to disagree with your observation and our experience of trainer lag ( December 30, 2016 reply #30 ) which is part of the reason why I wonder if our problem isn’t on the other end or even our connection speed.  https://www.dcrainmaker.com/2016/12/cycleops-hammer-trainer-review.html  


(Brian Chase) #5

CycleOps just released a new firmware update v31.31 which might address the lag issue (I experience it as well).  You can find links and details on the dcrainmaker review mentioned above starting with comment #195.  I have not tried it yet since I need to get a bluetooth Bluegiga BLED112 USB dongle first.  Hope this solves the issue!


(Paul Fish) #6

Brian,

Thank you so much.  I will update and report back on how it works.

Try ordering the Dongle from Digi-Key PN BLED112-V1.  I purchased mine for ~$19.00 all told instead of the ~$40.00 everyone else wants.   


(Paul Fish) #7

 

I’ve just updated my CycleOps Hammer Trainer with v31.31.  I had some problems updating because I updated Virtual Training 2015 first and it wouldn’t update my trainer.  Fortunately The program crashed before it caused the firmware to be erased on the trainer but I had a red LED on the trainer that required cycling the power to get back to functioning. I had visions of having to ship the unit back for repair. I got lucky.  So, I have a separate computer that had the older version of Virtual Training that I haven’t updated which allowed me to update the Hammer successfully.

So the good news is that the new version seems to make the Hammer seem a lot less lag.  When going quickly from a relatively flat surface to a 9% grade in the London Subway I seemed to be able to keep the momentum in a more realistic fashion. . Of course, there is also the fact that Zwift pushed out a new update just as I was going to try it out and that may or may not have contributed to the improved results. Regardless, it seems to work in a much more satisfactory way. Thanks to the unknown programmers who resolved the issue and thanks for your help.

 

 

 

 

 


(Brian Chase) #8

What an adventure this has been!  Cycleops released a beta for CVT software this week which has a link on the dcrainmaker comments.  Also, I actually just got an email today announcing a new version of CVT 4.2.0 and tried that version BEFORE the beta and it crashed each time on Win10 when selecting to update the firmware version to v31.031 (using the Bluegiga dongle).  So I then tried the beta version and it worked perfectly.  It might just be my personal experience but it’s worth noting I guess.

As for the new v31.031 fix? The lag time is definitely better for me but I would say it’s maybe 50% better.  On grade transitions of 0-5% the difference was noticeable and responsive but the dreaded escalator in London still has definite lag.  It feels bogged down at the top of the climb for at least 4-5 pedal strokes.

I hope Cycleops continues to tweak the firmware but it seems we are moving in the right direction!


(Paul Fish) #9

Brian,

I too had the same problem.  I’ve reported the problem to CycleOps. 

Yes, I think the issue has been “improved” but not fixed completely.


(Paul Fish) #10

I have to “backpedal” on my comments the other day about the Hammer lag being better with the last release of the software.   A few times that I rode the lag was less and the avatar didn’t stop dead while I’m putting out 300+ watts.  Other times it seems that the least little change in incline causes the avatar to stop and unclip no matter how hard I am pushing.  Since I’m just riding the course it’s not such a problem.  In a competition this would be really infuriating.

Does anyone have any insight into whether this is related to internet connection or is it just that the Hammer doesn’t play well with Zwift?


(Caiman Lieu) #11

 

I installed the firmware update from day one and it didn’t fix any of my resistance delay problems. I don’t think it will be fixed by software with a slow on-board processor. This means we will have to wait until Hammer 2.0 with a new faster chipset to fix it. It is certainly not a show stopper but it just feels very un-natural. In the last two weeks, I also have experienced a sudden drop of power (zero on Zwift) as I approach a climb even though my Garmin 1000 (yes I have my Garmin turned on while riding Zwift) is still showing power. This tells me this is a problem related to Zwift, perhaps not the Hammer. Who knows? I am just tired of complaining, as the weather has been nice outside so I spend more time riding outdoors and less time on my trainer.

 


(Caiman Lieu) #12

Forgot to mention that I used the Hammer from one day (sometime late last year) and never had this dropout problem until recently.


(John Carpenter) #13

I rode my hammer for the first time yesterday in London and experienced the same thing going up the esculator in a large group. Everyone went flying by and I slowly crawled up, something I never experienced on the Magnus. I was on the default 50% setting, not 100%. All firmware is up-to-date. 

I’ve not experienced any noticable lag on other climbs and have been very pleased with the improvement in that area versus the wheel on trainer.


(John Carpenter) #14

Has anyone sent an email to Cycleops tech support? They’ve been very responsive in the past with opening a ticket and following up.


(Paul Fish) #15

Yes, I’ve submitted a request for technical support.  They requested that I send them all of the log files that Zwift automatically creates.  Possibly you could contact them too and reference my support ticket number #(61714). 


(Ed Jenkins 67SEA) #16

I have also had the same problems. Today I did the latest update to the firmware and it made no difference and for the first time I was getting that snapping sound out of the rear unit, not sure what is up with that. 


(Caiman Lieu) #17

I had that “snapping sound”, which I described on DC Rainermaker’s blog a while back. If you guys having these problems I have had, please post them on DC Rainmakers blog so the world would know about them. I looked like a fool over there with the only one who had these problems while others were extremely happy with their Hammers.


(Brian Chase) #18

I sent a detailed email to Cycleops Customer Service last week covering the following:

  1. Lag/response issue (like London escalator)

  2. CVT program crashing during Firmware updates

  3. Wattage drop to 0.00 on climbs while shifting (happened during a race too!!)

  4. It’s hard to find the current Firmware info on the website. Please put a prominent link on the Product Page announcing the current Firmware version and instructions.

 

Cycleops Customer Service responded with, “We are aware. Thank you.”

 

So at least I now know they are “aware” of issues…   Anyway, I went through a long Zwift Ticket weeks ago and Zwift confirmed a 10ms Ping, fast internet connection, and I tried 2 different Garmin ANT+ dongles sitting under the crank.  I know it’s not communication lag.  I am obviously a bit frustrated but still hopeful that Cycleops steps up problem solving and gets a fix out.  Otherwise, the word will get out that they are having issues with Zwift and sales will take a hit.

BTW - I only had a “snapping” issue once right after the v31.31 update.  It was weird and very minor for me.  Just over 1000 miles so far.

 


(Paul Fish) #19

I’ve experienced the snapping too!  At first I thought it was chain alignment but turns out that is not the case.  When it happens I shift up and then down and sometime it will stop.  I’ll put it in as an issue at CycleOps myself.  I would suggest that more people bring these issues to the attention of CycleOps,


(Brian Chase) #20

When you say “snapping” is it like where the flywheel suddenly loses all engagement and then snaps back like the clutch is re-engaging?  I’d like to make sure we are talking about the same thing.