Custom workouts category missing [SOLVED]

Workout list is just blank.

I can creat workouts, use them, but they disappear when I exit zwift.

I’m using my iPad.

Not sure why you need a photo. It’s just the custom workout screen with my workout no longer there.

Exactly the same here. Can create, save, use the workout, save my workout but when I log in again I have to recreate the workout. This is a recent issue so it must be a bug.

I love the new interface (on iPad) that allows me to select a custom workout, and then choose a world/route.
BUT around 50% of the time when I log in my list of workouts is empty! Sometimes they reappear if I log out and in again.
NB: I’m not talking about the “old” interface which still exists where you first select a world/route, then bring up the workout list via the menu – this still works even though the custom workouts have been moved way down the list (grrrr!)

Several of us have the same issue. It’s been occurring since once of the recent updates. I am yet to see Zwift acknowledge the bug but maybe they will here.

Did you try the solution linked in the first post.

The one where you direct yourself to the old menu and select custom workouts from there? If so, yes. The custom workouts are not there either.

If it was something else please provide the link. Thanks.

Yes I have. So to make it abundantly clear, I am able to locate the custom workout folder. When I open it, it is empty.

Several people have the same issue all of a sudden. Once of your recent updates has broken the custom workouts.

This is a bug. Please don’t suggest what else I need to do. Please acknowledge the bug and advise when you envisage this will be fixed in a future update.


Do you still have the workouts on your PC in the workouts folder?

I think they’re using an iPad

I use an iPad and Apple TV

The custom workout folder seems to be back at the top of the list now.

I run Zwift on my macbook pro (2021 model, M1 Max).

Got back from an extended time away and discovered that all my custom workouts are missing as well. I’ve tried re-creating workouts, but they are gone the next time I login, despite existing in the “Zwift” workouts folder on my macbook.

Additionally, the link to my Today’s Plan workouts that my coach puts together is no longer showing up in the workouts tab.

I only use my custom workouts and my coach’s workouts. Needless to say, this is pretty frustrating to have to deal with.

Is there a fix yet for the missing workouts? How do I get Zwift to re-sync with all the existing .zwo on my macbook and how do I get the Today’s Plan workout sync back??

I have exactly the same issue …

Did you get your issue sorted out ?

No, still none of my old custom workouts in Zwift and still not saving any new custom workouts I create. Also still no link to Todays Plan workouts.

I am using an iPad and just double-checked with v1.32.0: custom workouts are empty if no trainer is connected - but visible if so. Consequently abroad a pre-selection is not possible since the device (an iPhone) is not connected to a trainer.

Hi I’m pretty new to Zwift, I was wondering if anyone could help, I’m trying to create my own workout, I’ve watched YouTube vids, but I’m not seeing the custom workout button in the training section,

As someone who ues custom worksouts, the new UI is a complete failure. I used to be able to easily access my TrainingPeaks synchronised workout for the day. There is now no wasy way to access it.

Complete retrograde step by Zwift.

1 Like

1.32.1… Complete failure