Critical power curve not displaying watts [1.39.0] [May 2023]

Since the last update or two (Mac OS), when you hover or mouse-over the Critical Power graphs in the ride summary screen, it doesn’t show wattage figures.

Searched the forums and couldn’t find such a report so am wondering if I’m the only one using this feature?

Came here to say the same thing. Noticed it last night, on a windows setup

1 Like

Ditto. Windows 10. Summary screen for Critical Power after ride - you can’t scrub the timeline for wattage. You only see the graph/curves w/o being able to hover over and see wattage figures.

Hi folks,

Thank you all for reporting. I’ve flagged this issue up at HQ.


Seeing the same issue since the most recent major update. Mine looks just like @C.CASS_Snyder_athlet 's screenshot. Not able to scrub the chart anymore. I use this feature after every ride so hope it’s a quick fix!

And it’s the same on Windows and Mac. Shows some garbled numbers at the bottom right corner and doesn’t respond to mouse over.

1 Like

Today’s update (V 1.1.6, launcher dated 11/3/23). Critical power bug is still there…(sad emoji).

Not that theres been any new updates, but it’s still not working for me either.

Yesterday’s update (1.4.2) seems to have fixed it!

Nice one!


Wonderful, I’ll have to double check my update version.

Confirmed. All good again!