Crashing with MacOS 10.15 Catalina

Hey Zwifters,

We have seen reports of game crashing after the MacOS 10.15 Catalina update. This is due to security/privacy settings that Catalina has introduced.

After installing the new OS, there should have been a prompt asking to allow Zwift access to the Documents folder. If this option was denied, or if the prompt didn’t come up, Zwift won’t be able to access the folder and will crash at launch. You will need to allow access to correct the crashes. Here’s how to do so:

  1. Go to ‘System Preferences’.
  2. Go to ‘Security and Privacy’.
  3. Click the lock icon at the bottom left hand corner in order to ‘unlock’ Privacy settings. Enter Mac password. to unlock (if it’s already ‘unlocked’, then skip this step).
  4. Click the ‘Privacy’ tab.
  5. Select ‘Files and Folders’.
  6. Click the checkbox for ‘Documents Folder’ below the ‘’ option
  7. Re-lock ‘Security and Privacy’ settings.
  8. Launch Zwift. If Zwift crashes again, try restarting your Mac and try launching the app again.

If you still find issues, please contact our support team.


Dear Josie,
I have been having the same issue with persistent crashing following update to Catalina. I have followed the ‘fix’ you outline (in fact, the privacy settings were already correct) and the issue has not resolved at all.

I have been in dialogue with Zwift support and they only offer the same fix as you and have now suggested going through the pain of rolling back to Mojave iOS.

Is anyone else having the same issue? Are there any other ‘fixes’?


1 Like

Hi Lloyd - If this fix did not work, could you send us the crash report? Thanks!

Hi Josie,

Thank you for responding.

I have already sent the files into the support team but the only solution being offered is the one you outline in your original post. The most recent advice is to roll back the Mac iOS update, which is not ideal.

Best wishes,


Thanks Lloyd - I’ll look for your inquiry and circle back to you.

Hi, I’m having the same issue.
I granted full disk access to to no avail.
The only workaround seems to be to start Zwift with root rights via the terminal.

As normal user Zwift throws an error message “unable to update Zwift App. Please confirm Internet connection and try again. Error: ZLM01” and exits.

Hi Lloyd, did you get your issues resolved?

I have the same problem…

The reason MacOS blocks this by default is that it is a privacy risk and should not be allowed without good reason.
Can Zwift explain why they need access to the folder where personal (not Zwift related) data is stored?


I have the same problem …

I had the same problem. I had to check both zwift and the zwift app to get it run. Would have been a lot easier had it indicated the need to access the folder in the first place when I first denied the prompt.

MY Zwift Run but every tie I ve to wrote password and Catalina open a “terminal” window". It is normal?

Hi @Josie.L

Do we know if the latest Mac 10.15.4 takes care of this issue do you still need to manually allow Zwift to access the documents folder.

I just looked, after I complete Step 5 - Files and Folders, I don’t have a checkbox to tick nor do I have any documents folder below the

See screenshot.

Could any of this lead to why my rider/wattage is not showing in Zwift thought my speed/cadence sensor is paired.

Hi Rob - I don’t know if our team has checked this OS specifically just yet. As for your wattage - please check that you’re set up correctly, and change of battery in case it helps. We haven’t seen any large issues arise for that specifically. If you’re still having issues - send us a message at


Hi @Josie.L

Thanks for the answer. I missed Support’s Phone call this afternoon, I was on a conference call and couldn’t speak with the tech support worker unfortunately.

I got it working on my work PC running windows 10, however for some reason on both mac iOS (Phone & Macbook) I’m not making much progress having my wats show up.

Hopefully support will connect with me again shortly.


I also have an issue since I’ve updated Catalina but my problem is that my Kickr is no longer discoverable using bluetooth in the app (it is discoverable in the wahoo app and on zwift companion). Zwift Companion is not a long-term fix because ERG mode is all over the place.

I have bought an Ant+ cable and this did find my device (but named differently) however it dropped after 40 minutes of a training ride; not sure if the drop is due to the app/computer or the ant+ device itself.

I am also frustrated with the lag in getting a response from zwift; Wahoo were able to respond within 12 hours…

James, I’m having basically the same issue. I see the Kickr (I actually see 2 kickrs even though I know only 1 is in range) as a selectable BT device in both the Power and Controllable Trainer device selection menu. But once connected both go to “No Signal”.

@James_Ogilvy_FOT and @David_Bossert_TT1D

Welcome to Zwift forums. There’s a thread upstream that references the folder permissions you need to grant in Catalina OS. This thread goes into that process in more detail. Would you try this and let us know how that worked?

I’m having the same problem with Catalina. As soon as try and start it and press the “Let’s Go” button it just crashes. I have tried all the suggestions in this thread plus the one @shooj mentions


The “Let’s Go” screen is the launcher app that triggers the actual game app. If the game app is crashing at that point, another possibility is that a graphics driver is out of date.

Please see this article on our support site.

One other thing: do you have a cloud sync application running in the background? Like iCloud or TimeMachine or something along those lines?