Crashing with MacOS 10.15 Catalina

Hi Josie,

Thank you for responding.

I have already sent the files into the support team but the only solution being offered is the one you outline in your original post. The most recent advice is to roll back the Mac iOS update, which is not ideal.

Best wishes,


Thanks Lloyd - I’ll look for your inquiry and circle back to you.

Hi, I’m having the same issue.
I granted full disk access to to no avail.
The only workaround seems to be to start Zwift with root rights via the terminal.

As normal user Zwift throws an error message “unable to update Zwift App. Please confirm Internet connection and try again. Error: ZLM01” and exits.

Hi Lloyd, did you get your issues resolved?

I have the same problem…

The reason MacOS blocks this by default is that it is a privacy risk and should not be allowed without good reason.
Can Zwift explain why they need access to the folder where personal (not Zwift related) data is stored?


I have the same problem …

I had the same problem. I had to check both zwift and the zwift app to get it run. Would have been a lot easier had it indicated the need to access the folder in the first place when I first denied the prompt.

MY Zwift Run but every tie I ve to wrote password and Catalina open a “terminal” window". It is normal?

Hi @Josie.L

Do we know if the latest Mac 10.15.4 takes care of this issue do you still need to manually allow Zwift to access the documents folder.

I just looked, after I complete Step 5 - Files and Folders, I don’t have a checkbox to tick nor do I have any documents folder below the

See screenshot.

Could any of this lead to why my rider/wattage is not showing in Zwift thought my speed/cadence sensor is paired.

Hi Rob - I don’t know if our team has checked this OS specifically just yet. As for your wattage - please check that you’re set up correctly, and change of battery in case it helps. We haven’t seen any large issues arise for that specifically. If you’re still having issues - send us a message at


Hi @Josie.L

Thanks for the answer. I missed Support’s Phone call this afternoon, I was on a conference call and couldn’t speak with the tech support worker unfortunately.

I got it working on my work PC running windows 10, however for some reason on both mac iOS (Phone & Macbook) I’m not making much progress having my wats show up.

Hopefully support will connect with me again shortly.


I also have an issue since I’ve updated Catalina but my problem is that my Kickr is no longer discoverable using bluetooth in the app (it is discoverable in the wahoo app and on zwift companion). Zwift Companion is not a long-term fix because ERG mode is all over the place.

I have bought an Ant+ cable and this did find my device (but named differently) however it dropped after 40 minutes of a training ride; not sure if the drop is due to the app/computer or the ant+ device itself.

I am also frustrated with the lag in getting a response from zwift; Wahoo were able to respond within 12 hours…

James, I’m having basically the same issue. I see the Kickr (I actually see 2 kickrs even though I know only 1 is in range) as a selectable BT device in both the Power and Controllable Trainer device selection menu. But once connected both go to “No Signal”.

@James_Ogilvy_FOT and @David_Bossert_TT1D

Welcome to Zwift forums. There’s a thread upstream that references the folder permissions you need to grant in Catalina OS. This thread goes into that process in more detail. Would you try this and let us know how that worked?

I’m having the same problem with Catalina. As soon as try and start it and press the “Let’s Go” button it just crashes. I have tried all the suggestions in this thread plus the one @shooj mentions


The “Let’s Go” screen is the launcher app that triggers the actual game app. If the game app is crashing at that point, another possibility is that a graphics driver is out of date.

Please see this article on our support site.

One other thing: do you have a cloud sync application running in the background? Like iCloud or TimeMachine or something along those lines?


Enabling access to my Documents folder in my Security and Privacy settings after upgrading to Mac 10.15 Catalina fixed the issue for me.

However, I strongly feel that this shouldn’t be required. There is no reason Zwift needs to be able to read all of my Documents. My Documents folder contains personal information, and I shouldn’t have to give Zwift access to it. Is there any way a different folder could be used? Downloads could be slightly better (but not much), but a directory that only Zwift has access to would be best. This is a notable security/privacy concern and degrades my trust in Zwift as a user.

Thank you for your consideration!


Has there been any movement on the fix for this? Im having the same problems.

I’m running latest version of Zwift on the Mac as well as the iPhone and my Mac is up to date. I’ve tried the suggested fix including turning it off/on again.



Same issue but only started happening in the last week - Ticket and crash report sent to Support - waiting on reply. Have installed latest version of Zwift, updated all my MaC Os and drivers accordingly, plus followed the details listed in this thread, still no joy as yet.