couldn't find TACX T2180 Vortex Smart in the trainer list when pair ANT+ equipment


(Jacky Wong) #1

Not a big issue, just want to double confirm…
When I try to pair the ANT+ equipment, the system asked me to select the trainer. However, I couldn’t find TACX Vortex Smart in the list.


(Eric C. (Zwift HQ)) #2

Hi Jacky,

It’s currently a power meter, not a Smart Trainer, as we are only capturing their ANT+ wattage transmission.


(J Lamb | recovery begins) #3

Just an update as the Tacx Vortex Smart (T2180) is now a fully support Controllable Trainer within Zwift - fully supported resistance, power meter, cadence, and speed.  Using on everyday now on Zwift.


(Jackie Morettin) #4

Just trying my new Tacx Vortex Smart (T2180) with the Zwift free trial.  It found it as a power meter and gives me speed and cadence but not any resistance.  I cannot find it under Controllable Trainer.  If I sign on as a member, not just free trial, will it give me resistance?  Thanks


(amy Dimberg) #5

I just created an account and still cannot pair my T2180 as a Controllable Trainer.  It did pair for power and cadence. What else can I try?


(Pete GameCock WBR (D)) #6

Try hitting search on Controllable Trainer and spin the crank. Once it shows up as an option, click on it, hit OK and you should be good

 


(J Lamb | recovery begins) #7

Hi Jackie &Amy.  I’ve been using the Tacx Vortex Smart Traner (T2180) since October and have been straining up the Zwift hills since then.

<edit>Make sure the model number of your Vortex is T2180 as there is a non-Smart version of the Vortex</edit>

If you haven’t already, make sure you have upgraded the firmware of the unit to the latest by using the Tacx Utility app - downloadable from the Apple App Store.  Tacx used to only have an iOS version of the app though I know they had plans to also provide an Android version.  If you don’t have an iOS device, have a friend with an iPhone 4s or better stop by for 5 minutes and:

    - install the Tacx Utility app

     -  power on your Vortex

    - run the Tacx Utility App

    - you should see a Tacx device like “Tacx Vortex 16767”, select it

    - with the device selected and now connected, select the menu in the upper-left hand corner (three bar icon) and select “Update” and follow the prompts.

Once your firmware is updated, if needed, and your Ant+ donggle is in your computer, launch Zwift and login.

Once the pairing screen shows, it may look as if the system has already found your Trainer; it has and it hasn’t.  Most likely it found it as a Power Soure.  Click the Search Button for Controllable Trainer and Select the only Option - something like Trainer 16767.

Your Tacx Vortex Smart Trainer should now have the resistance controlled.

Ride On,

    John


(J Lamb | recovery begins) #8

Jackie & Amy,

I just jumped on and Zwift has pushed out an update today so having to click  the Search button under Controlable Trainer doesn’t have to be done every time now.   

If your trainer is just showing as a Power Source (highlighted blue) and not also a Controllable Trainer, unpair all selections and then click search under Controllable Trainer, select the Ant+ Trainer 16767 option and now notice that all three boxes go blue for Power Source, Cadence, and Controllable Trainer.

If you are using a heart rate monitor, pair it too.  

It looks like Zwift is now going to keep the pairings between rides!!!

 

Hope this helps,

   John