Connection Disconnected

Thanks for the reply! I have a typical “person with a small apartment and family”-setup: My bike and trainer is in the basement of the building with the router in our living room in the third floor. Luckily the distance from router to trainer is not so long, its located directly under the living room. So the distance is not the problem, works fine with the 2.4Ghz. However, I suspect that the router might not be the best. It is a Sagemcom 3890. And the 2.4 ghz also has a bunch of ovens, speakers and devices connected to it. So I guess its a mess? :stuck_out_tongue:

I have considered a new router, but it might also help to try to get some devices over from the 2.4 to the 5? The 5Ghz does not have a long enough reach to give me a stable connection in the basement.

You could try extending your network via Powerline networking, assuming you can’t easily drop an Ethermet cable down into your basement.

If the router is just not coping well though, those might not help. Hard to tell without trying it. Have you at least tried rebooting your router to see if that clears up any issues?

1 Like

Thanks, will look into Powerline! Regarding the rebooting, I have a ritual before every ride where i pull the plug out and wait five sconds and plug it in again. Basically a part of the pre-ride routine :smiley:

Is it the TCP dropouts that are the problem? The UDP dropouts are more about other riders positioning compared to mine, for example?

as mentioned by @Steve_Hammatt its a connection dropout rather than equipment dropping the Bluetooth, might be worth looking at how strong a signal you have on wifi, i have a movable antennae on my bluetooth and depending on where it is positioned depends on how strong a signal it is

1 Like

Thank you! Is there an easy way to check signal strength? :slight_smile:

click onthe wifi icon then go into properties and scroll down it should say something along the lines of 86/72 for example, does depend on the type of wifi adapter you have and the router, might look at what channel the router is broadcasting the 2.4Ghz signal and swapping to a less crowded one

1 Like

Very useful, thanks! Will try to look into the different things you guys have suggested, and post again if the problem isnt solved. Until then, thanks and happy riding :smiley:

1 Like

Yes, that’s right.

1 Like

I’m having the same problem as others here. Last November I got a 100mbit internet BT FTTP (full fibre to the BT hub in the house) connection which has been very reliable. Late December I started running Zwift on a new Apple TV (rather than on Android). The Apple TV is connected wirelessly to a router in the garage (4 feet from the Apple TV) that is connected to the main BT hub via an ethernet cable. For 3 months everything has been perfect. Then, last race but one it disconnected mid race and like someone else said, you pedal like mad to try and not be dropped as you can’t see anyone. Todays race was perfect, but it disconnected on the warm up. The equipment shows no signs of disconnects with anything else.

1 Like

Losing the other riders like that means you have lost your connection to Zwift’s servers. I’m afraid this is likely to be a problem at your end somewhere.

You mentioned that your Apple TV is connected wirelessly to a router. I would try using an Ethernet cable to connect, since it seems to be close by.

Thanks Steve, I should try that. The reason that I havn’t so far is that I use the sterzo steering add on and therefore I have to have the bluetooth connections handled via the companion app (on android) as apple TV does not have enough bluetooth connections. I thought that maybe if apple TV connected to the router via ethernet then the criteria that the apple TV and companion app on android connected via the same wireless network would not be met.

My Apple TV is on Ethernet but my companion device is on wireless and it’s fine.

This all depends on your routing. As long as the two devices can see each other on your network then it doesn’t matter how they’re physically connected. There are lots of variables here though, and some people seem to find that their routers stop devices on different parts of their home network communicating. Mesh networks can be problematic (though I have a mesh network and it’s fine).

Try it and see.

There’s something screwy going on for a lot of people since the last update. My own experiences documented here:

TL;DR: cross-platform (brand new Windows 11 PC with updated drivers connected via ANT+ as well as an AppleTV4k on BLE) both disconnected from sensors yesterday.

Nothing has changed in my RF environment, I never use the Companion App as a bridge and my WiFi router (not mesh) is located 4-meters from my Zwifting station.

Hopefully this is just a transient, post-game-update issue but I’m watching for ongoing issues like a hawk now. A year of zero hiccups… and now this.

1 Like