Computrainer Workout mode beta - higher watt lag


(Daniel Stark) #1

First, my setup:

Computrainer in Erg mode (cadence not hooked up, don’t think that matters).
Bike with Quarq and a garmin 520 in indoor mode (the pwoermeter and swift track nicely). I have the garmin file in addition to the file in Zwift for comparison if your developers need them.

I did the 2nd day of the 12 week FTP workout just now and failed both of the 5X10sec @ 440 watt sections. It made me sad. Worse is that I don’t think I actually should have failed. The resistance on the computrainer would not raise fast enough but a combination of high cadence and it eventually kicking up the resistance got me over for a significant portion of the interval on the garmin/quarq combo. Zwift would often not update the current wattage (I don’t know the averaging it’s doing but perhaps it could be lowered or power could be sampled more on shorter efforts).

I tried to hit the intervals differently a few times. Like starting my effort before the red gate or waiting until 1 second in but couldn’t find rhyme or reason to why swift would update the power sometimes but not others. I’ve read about ramp rate issues with the kickr on the wattage list ad nauseam but I’ve never experienced in on my Computrainer before.

Let me know if you’d like the garmin file. Other than this I’m really liking the workout mode.

Thanks,
Dan


(Steve C) #2

Similar thing with a Bkool Classic - the resistance ramps up over a couple of seconds and the power takes a few seconds to update on the screen too - so the first part of the 10 second intervals are under power. Similarly, the resistance keeps high for a few seconds after too.

In terms of doing the full interval, just keep going after the 10 second interval completes - the ‘lag’ will mean the 10 seconds at the required power will be done - just further along the road.


(Jason K) #3

Dan, depending on when you did the workout, it sounds like the issue you’re seeing could be related to using a Quarq and a Computrainer at the same time. Prior to the last update, if you rode with a power meter and a smart trainer at the same time, ERG mode wasn’t disabled, and the power meter would give different readings than the smart trainer, causing inaccurate readings.

Since the last update, ERG mode is now disabled if you pair a power meter, so I’d recommend giving it another try, either pairing both or just using the Computraier/Quarq.

 


(Jason K) #4

Steve, there’s some issues going on with BKOOL right now that we’re investigating. If you haven’t already submitted a support ticket to bit.ly/zwiftsupport, please let us know what you’re seeing and all the senosrs you’re using for your Zwift setup. Thanks!


(Daniel Stark) #5

Jason, I only have the Computrainer paired the Quarq I’m using standalone on the bike. I actually don’t even have an ant stick in the computer.