Completed Challenge. Message won't go away. [December 2022] [1.32] [SOLVED]

I just completed an event and gone through the usual upload procedure at the end but when trying to look into my activity, it says it is still ongoing. The activity was on a Windows 10 PC with latest updates of the game. Anyone any ideas?
I think as a consequence I am currently also missing the just issued Concept Bike, but actually having a video which shows the 50k challenge has been completed and I should choose another, but likewise it doesn‘t show up in my missions completed section. As said I am pretty sure that the latter is just a knock-on effect of the first.


Hi @Robert_Lohmann

Welcome to the forum.

The first thing that comes to mind is, do you have Zwift on multiple devices, having Zwift open on multiple devices will cause this to happen.

Thanks Gerrie,
Actually I have installed the Zwift app also on my iPad, but did not have it open during the session, but just the Companion app. Meanwhile the activity has been shown as close and as far to the activity everything looks normal to me.
Well, except for the fact the Everest Mission is still not showing up in the achievements section plus the bike - maybe as expected if the mission is not recognized as completed - is also not there. I have just sent an email to the support to check on this. My best guess it is a glitch with the new release which has just been published. Attached are screenshots from directly after the event even after uploading the records.

1 Like

Hi @Robert_Lohmann welcome to Zwift forums.

Shuji at Zwift HQ here. Clearly what you’re describing shouldn’t be happening. I’m going to pull your recent game logs and will forward to the team to investigate.


Riding today doing Quatch Quest about 20 min in I kept getting the “Tarmac Unlocked” notification…again and again…about every 3 seconds after the last one went away. I’m on an iPad Pro (2018) running the latest version. This bug prevented me from properly saving my file kinda of. The achievement kept popping up even when stopping my ride. On screen buttons didn’t really work. I eventually closed out of the program and closed it on the iPad. When I reopened it allows me to pick up where I left off (Though apparently it had uploaded where I had stopped to starva, garmin etc). I finished my ride which was completely uploaded to Zwift but still appears corrupt. I started a new ride and the message kept popping up. I uninstalled Zwift and reinstalled it and the message is still popping up. Any thoughts?/

1 Like

Hi @Matt_Peters welcome to Zwift forums.
Shuji at Zwift HQ here. I merged your post into this discussion under way.

The common symptoms you and @Robert_Lohmann are reporting are buggy behavior of unlocked achievements for completing Challenges. Matt - for you sounds like you completed the California Challenge and unlocked the S-Works Tarmac, is that right?

Robert, I see in your screencap that you unlocked the Zwift Concept Bike (aka Tron Bike) for completing the Everest Challenge. I looked at your server logs and see that you did in fact complete that challenge (congratulations!).

The team here is investigating what’s happening and we’ll update this thread as we have news to deliver. If others reading along have similar reports about weird behaviors when unlocking Challenge achievements, please weigh in here.


Many thanks Shuji, sounds promising! :grinning:
What I also realized is that though yesterday‘s event at some point in time has been accessible in my profile activities, it is listed there with approximately 5km less than you would see on my screenshots, which I would not care too much as it has been on the way down. In addition though I took a couple of screenshots at the top of the Alp du Zwift and also on the way down, and all those screenshots did not show up at the end at all.

I can also subscribe to this repeating banner Matt described, which was nice in a way but likewise enerving as I could see the riders‘ list at the right always just for some seconds before it has been covered again by the banner.
And I can also confirm that during trying to save the route the PC app has gone a two or three times into a ‚not responding‘ mode, but I have been patient as I saw a high CPU load and other activity from the zwift.exe in the task manager, and the program always got back and finally seemed to be completely saved which has been just halfway correct.


Same problem with the emonda unlock. Restart die nothing, im on a pc.

1 Like

If your on pc but are able to log on via your mobile that should clear the issue. Logging back onto your pc should find you with the bike in your garage and the pop up gone, just a work around while Zwift does its thing.

1 Like

same issue with the emonda unlock

1 Like

Many thanks, B.B., this actually seemed to help. In fact on my iPad I tapped now into the same issues that I even cannot finish any ride due to the ever popping up banner and a completely unresponsive app there. I gave it a try also on my iPhone, and hurrah! :smiley: There it was already waiting in my garage - the Tron (Concept) Bike. Finally! I did not even need to start any workout, it has been just there. So I selected it, and now also everything on the iPad and the PC seems to be fine except for that even though I could choose another mission (e.g. the California one) and seen that the Everest challenge has been completed, it still doesn’t show up in the Badges menu under the Missions completed section. And by the way as a side note, why is it so unintuitive to get the status on the progress of a mission, i.e. why do I need to start a ride to see this status, i.e. why wouldn’t it be e.g. under the Badges menu listed as Mission in progress?

Anyway, I am not sure whether the support team has worked in the background on my particular issue so it has been just a coincidence that just at that very moment (some mins ago) I had the Tron in my garage, or whether it was really the trial on the iPhone.
So, looking forward to hearing some final comments from the support team. :slight_smile:

Hello! I have the same problem. I complete the Everest Challenge and the message to pick up the concept bike won’t go away. The bike is also not seen in the garage.

1 Like

Also happening with me for Trek Emonda - I’m on Android and the banner won’t allow me to save my activity.

Can the activity be recovered if I force close the app?

Any chance to login from an iPhone (see my comments from above in response to B.B.‘s hint)?

Thanks for the hin, but no, it did not work

Hi Shuji

Thanks for the quick response! The Tour of CA does seem to be the “issue” (though reading down it seems like any challenge). I switched to a different challenge and had to completely close Zwift and start a new ride. Only then did the banner stop popping up. However, if on that new ride I turn back on the Tour of CA challenge, the banner keeps popping up again even if I switch back to a new challenge. The only way to make it stop is to keep the new challenge and then completely back out of Zwift again. Also, as I think I saw in another post the original Tarmac is not actually in my garage even when switching to the new challenge and having Tour of CA marked complete. Hope this helps track down the bug!!


1 Like

Logging in from my phone solved the issue for me.

I unlocked the Trek Bike reaching my 88something today and I also had that flashing note. Very annoying, but I never got the bike. My avatar did reach top of the everest and the statement that my mission was completed.

I am getting spammed with the Pinarello Dogma 8 . Comes back every 20 seconds or so.