Complete Workouts show in activities but disappear from plan list

The last 3 workouts I’ve completed in Build Me Up have disappeared from the listing in Plan but show as done in my Activities.

What am I missing?

1 Like

They’re not showing at all. The 3 I screenshotted were the last 2 for week 6 & the first 1 for week 7.

Having completed them they now no longer show in the plan listing/schedule (which previously had 5 workouts in each of those weeks).

Each workout I’ve completed since Uphill Battle has disappeared yet still shows in my activities.

1 Like

I’m having the same issue, its annoying, but at least we are able to do the new workouts on time, and prior workouts are not showing up as ‘not completed’, so there is that…

1 Like

2 of the 3 have now reappeared under the Plan as ‘expired’ & the other is now showing as due in 19 hours?!


I’ve been able to manually mark them all as done - let’s hope the next few don’t go the same way.

1 Like

Same Problem ! Workouts done but not marked as done in the plan


I have had the same problem on the Build Me Up plan too. It has happened consistently since 25 February. I recall a game update being applied around that time so it could well be a bug in that update. It worked fine prior to that.
Looks like the Zwift engineers have a task…


I have the same issue. Training plan BUILD ME UP. Until the last update under iOS it worked fine.
Hope that support is already looking into this

1 Like

Lots of threads about this, its a known issue

1 Like

I am having the same issue in the “6wk Beginner FTP Builder” training plan. I am glad you are aware of the issue and look forward to a fix.


I’ve had the same issue on “Build Me Up”. After I complete the workout it appears to white out and not allow me to select it until it expires.

I’ve found a workaround where after I complete the workout and save, I relaunch the app. It’ll show my workouts to select like normal but with one completely blank where the workout I just did was. if I force close the app (I’m using Apple TV) and relaunch it, it then allows me to select the workout again. If I click “view entire plan” I can then select “I did it” to get credit for it in the plan.

Hoping for a real fix soon since it hit me in the middle of “build me up”.

I have same bug in FTP builder training plan. I noticed that the name changed to ”6wk beginner ftp builder” instead of just ”ftp builder”

1 Like

Same here! BUILD ME UP plan, missed Poutpourri and Baffling Blue , two in a row.
I marked it as done outside …but…really annoing…

1 Like

Same PROBLEMS !! DIRT DESTROYER PLAN not marked as done in the plan!! aple tv

So i am having this problem too and have for 3 weeks. I wonder whether this has something to do with Apple TV. Are others also using that to do their workouts?

This seems to only effect iOS devices, works fine on Windows 10 not sure about Android.

Zwift is aware and working on a fix.

Same problem. Using an IPad.

I have the same problem.
after 7 weeks the Build me up stops, and I have to start all over again, I can not contunue in week 8 or further, provided I wait 47 days :scream: :sob: :hot_face:

Knows someone how I can start in week 8?