Companion not working IPhone 11

Since yesterday my companion do not work, I have an IPhone 11 and it usually work, I try with android and it work but not with my Iphone, I have try everything they told online. Please help

Hi @Steve_Hayfield and welcome to the forums.

Can you be more specific on what isn’t working… is the app not even opening, or is it not connecting to the game when you start up Zwift? What is the exact problem?

Not connecting to the game @Mike_Rowe1

check to make sure your iphone is on the exact same network as the device running the game. You might have a 2.4ghz and a 5.1ghz wifi channel, put them both on the same one. You might also have “wifi assist” enabled on the phone, disable that feature.

1 Like

Thanks Mike - just typed that up :-{).

I’m on the same network already

It should work then… try restarting the wifi router and phone, try again.

Still not working :frowning_face: @Mike_Rowe1

check the device permissions:

Device Permissions

If you’re running Zwift on an iOS mobile device, you must grant Zwift Local Network permissions to allow the app to pair and communicate with the ZC app:

  1. Open Settings on your iOS device.
  2. Select Zwift and ensure Local Network is turned on.

https://support.zwift.com/en_us/issues-with-zwift-companion-app-HkWqU6hGB

A few other suggestions:

Remove and reinstall Companion app

Reboot the router and all the devices you’re using

Put the phone in airplane mode and then manually enable WiFi

Configure the router to rename the 2.4GHz band to a different network name, so you force everything onto the 5GHz band for sure

Hi, thanks for all your answer, I have try everything you told me but unfortunately it’s still not working, if you have any other ideas feel free to tell me, @Mike_Rowe1 @Ray_Ruyack_Cryo-Gen @Paul_Southworth

I am not an Apple user, but there is something like WiFi assist (or similar?) - you should make sure, that the phone cannot use mobile Internet when using ZCA. I personally (Android!) use Flight mode and WiFi and had never problems.

The companion app has also stopped opening game mode for me since the last update. I’m using an android phone and a windows computer.
I always used to work fine and nothing has changed with my network. I have also tried connecting both devices to a wi-fi hotspot and turning 5mhz on and off on my home WiFi, as well as all the other suggestions I could find on the forums.
Looks like this is a bug?
Kind of frustrating as it means I am unable to use my Zwift play controllers as the laptop Bluetooth connection isn’t stable enough (I used to connect through the companion app).