Companion App blue screen [November 2021] [SOLVED]

I get a blue screen that goes nowhere when I try to open the companion app. By shutting my phone down and logging in it finally gets up and running. However, it then only connects intermittently when I am cycling on Zwift. Most of the time it just sits on the home page. I use an iPhone and iPad. Very disappointing. Is there a fix coming?


I have had issue with Apple TV (latest 4K) and MacBookAir running Zwift. Used two different networks. The Companion App transiently switches to the Game Controller on an iPad Gen 6 and iPad mini Gen 6, the crashes back to companion app. Sometimes the app won’t even load. iPhone 13 mostly loads app but sometimes bluescreen. Can sometimes get the iPhone to run as a stable game controller. All apps fresh instal. iOS 15.1 and OS 12.0.1

Thanks for flagging the reports of the blue screen on the Zwift Companion app. We are investigating this as a separate issue form the white / blank screen in the iOS Companion app for now.

If you’re getting stuck on the blue splash screen, please tell us:

  • What smartphone / tablet model are you using to run the Companion app?
  • What OS version is on that mobile device?
  • Which version of the Companion app is installed? To check in the app itself:
  1. Open Companion
  2. Tap “More”
  3. Tap “Settings”
  4. Tap “About” to see the app version
1 Like

I just reloaded ZCA 3.30.0 on:
iPad Air 2
IOS: 15.1

I had ZCA running and launched Zwift then started a ride. On ZCA the ride screen flashed up then went back to home screen.
Hard close ZCA on iPad then open again and it only opens to the blue Zwift screen can’t get the home screen.

ZCA 3.30.0 works fine on:
iPhone SE
IOS: 14.8.1

In both cases running Zwift on:
Macbook Pro M1 2020
MacOS: 11.6

1 Like

I get this issue, sporadically, on the following devices running ZCA (all running 3.30.0):

iPhone 5S: iOS 12.5.5
iPhone 13 Mini: iOS 15.1.1
iPad (5th Gen): iPadOS 15.1 (this is separate from the map issue, as sometimes I don’t even get past the blue splash screen)

Exact same issue here. Blue screen, or home page after hard restart. If in ride, Loading Map page slides up then falls back to home page.
iPad 5th gen A1822, os 15.1, ZC version 3.30.0 (1172)


iPad Pro (9.7”) iPadOS 15.1
IPad Pro (12.9”) iPadOS 15.1
iPhone 12 mini iOS 15.1

All run Zca 3.30 (1172)

All have issues opening the companion app, freezing on the pale blue Zwift splash screen, force close the app and reopening up to 4 times before it opens…… but as per the other thread the map / workout dash board refuses to stay open for more than a second.


I have the same issue, the companion app is not working properly since the app upgrade to include Neokyo.
I have had issues on both an Iphone 12 IOS 14.8.1 and an ipad pro running 15.1.
Zwift companion app version 3.30.0(1172) on both devices.
I’ve had to do multiple app restarts (restarted the phone as well) just to get the app working. It then doesn’t get into the current session.
On the ipad, it gets into the app, starts loading my current session (map) and then the map vanishes to not be seen again.
This is very frustrating.

1 Like

Same issue here (stuck on blue screen). Running the latest version of the app on iPhone 7 (IOS 15.1). Have tried reinstalling and restarting the app on a number of occasions to no avail. Strangely if I am scheduled for an event that notice will appear on the blue screen (join event?) but nothing else works.


I have had this issue since updated to CA 3.30 last week on both iPad and iPhone.

  1. iPad - 7th Gen. OS 15.1
  2. iPhone - 12 mini OS 14.8.1

Have deleted and reinstalled CA - not resolved.
Have tried Wifi off/on - this occasionally resolves but it’s only temporary and get same issue next time try to open.
Would say the problem is not consistent - sometimes opens after slight delay but every other time just sits on the blue screen waiting, waiting, waiting.

Thank you for at last recognising this as an issue.

1 Like

Suffering same issue here, app stuck on splash screen.

Same here since the update. usually killing the app and start again fixes it.

Iphone Xs
iOS 15.1
Companion 3.30.0 (1172)

I know the white screen when it syncs into game is a different issue but i can resolve that by flicking my wifi off/on on the iPhone.

Same. IPhone 12Pro
Companion 3.30.0 (1172)
Server 1.264.1

My fix for the blue screen/hanging on the companion app is:

Switch off wifi and open the app on my mobile data network. Once it’s open, switch on wifi, and it works fine in conjunction with zwift on my laptop. (It works fine as a stand-alone app on the data network too, but not so good when actually riding on zwift.)

It feels like the app is struggling to connect on the wifi network for some reason.

Oh I should say it’s a pretty new iphone 13 mini with iOS 15.1.1


Same here.

Mostly I need to close and reopen the app 2-3 times.

Running on iPhone 12 pro with iOS 15.1.

App-Version: 3.30.0 (1172)
Server Version: 1.264.1


Almost exactly the same here - sometimes blue screen, other times not! Forcing a close and retrying usually works.

iPhone 12 Pro running iOS 15.1.1

App-Version: 3.30.0 (1172)
Server Version: 1.264.1


Same problem with my iPhone XR and updated to IOS 15.1

Barry T

Can also confirm my iPhone 12 mini still doesn’t like the zca on iOS 15.1.1 either

I’m getting the blue screen on the companion App and a log in error on the Apple TV App. I can’t use either. I have an iphone 11 running 15.1. Apple TV is 4th generation. I can’t open the companion app beyond the blue screen with logo but all my apps on my phone are up-to-date.


1 Like

@David_Lacerda: Have you tried changing the language on your ATV, as has been suggested on that thread, to remedy the log in issue (for the Zwift app, not ZCA):