Can't U-Turn [October 2021] [1.18.0]

Hi, I acquired the U Turn Bug on November 2 while riding Richmond but I seem to have a worse variant of this Bug.

On all of my ride attempts since November 2, when I start the ride I have to put out an unusually and disproportionately higher number of watts to move at a normal speed. As an example, it takes me 300W to go 30KPH on the flats (Important to note I’m not limited to the U Turn Bug reported maximum of 24KPH).

Once I reach 30KPH at 300W, I can then soft peddle and my watts seem to drop appropriately however, my speed will remain high (ie: Only putting out 50W but moving 30KPH).

I have a Tacx Neo 2T and all updates are current. I have an Apple TV and all updates are current. I was using the latest version of Zwift. I tried riding a variety of courses. I tried playing around with the U Turn button, etc but nothing would fix this issue and I have been unable to ride since November 2 as it was pointless.

It’s important to note that during this time period I trialled TrainerRoad, Rouvy and Fulgaz and they all worked flawlessly without any technical issues whatsoever.

Today I installed the November 18 release and this did not fix my issues at all.


Have you powered it off and back on, do you force close Zwift after every ride?

I have an appletv and kickr bike. I also had the u-turn problem about a month ago. I uninstalled zwift from appletv and reinstalled, has worked great since.

I can confirm the bug is fixed for me in 1.19.0.
Many thanks to the Zwift community and Zwift staff.

I previously reproduced the issue three times on Road to Sky attempting to u-turn on the way down after completing the route.

For the rest of this last month I have been successfully using the workaround of selecting Jungle Circuit then manually navigating off course to the Alpe du Zwift so that the route never completes.

This evening with the 1.19.0 release, I went back to using Road to Sky and u-turned successfully several times after going through the spinner at the top of the Alpe to complete the course, going round the flat segment and desending.


Excellent news. Thanks Marvin!

Definitely having the same problem. After I try to turn a couple times, then my avatar slows down to 12 or 13 miles an hour. No matter how many watts I put in.

When is the last time you attempted this, Curt? The 1.19 released earlier today should resolve the issue.

Today’s update fixes it, make sure you are on the latest version

1 Like

Mike, I appreciate you taking the time to reply.

I did try powering Apple TV on/off without success.

I wasn’t aware of Force Close and haven’t been using it. I just tried a couple of short rides using Force Close but this wasn’t the trick either.

Thanks anyways,

Very Strange Bill, I did hear that the new apple TV remote buttons can cause issues too, are you using that perhaps?

Unfortunately, these issues are happening with the new update. I did not have these issues before.

To confirm, this still happened after the 1.19 release today? If so, can you please answer the following:

  • Are you trying to turn at the intersection of a route or just a normal u-turn within the game?

  • Was it in a route you selected or a free ride? If it was a route you selected, was it attempted after the route was completed?

Mike, still using my old remote.

I’ve been using the same setup on Zwift for almost a year now with no previous issues at all.

Got the bug on Richmond shortly after unsuccessfully trying a U turn and then got locked at 24KPH on a downhill.

I was at the end of my ride anyways so I kinda shrugged it off and ended it.

Next ride I think was London. I did an immediate U turn and have now been stuck ever since with the problem I’ve described.

Tried all the basic fixes with no success. Found this thread and was hopeful the new release would fix things for me but unfortunately it didn’t.

Hi Paul, I’m sorry I responded a little too quickly. The U-turn issue has been going on for some time, on the previous release. I have not tested it on this current release.

I thought you were responding to another, I had made about this current release. I am on Apple TV, on the most current release and the elevation profile on the screen does not match the resistance I’m getting from my kicker core trainer. That is completely new with this release.

1 Like

That bug has been around too, workaround is rolling back the firmware on the kickr

1 Like

Well, not for me. I had been doing fine on the previous Apple TV release, and the kicker core release that I was on. After experiencing the issue in zwift, I noticed that now there is a kicker core firmware upgrade. So I have now done the kicker core firmware upgrade. Later today I will jump back into zwift and see if this issue still exists.

Same for me.

I will try it later today when I get back on Zwift. I am on the most current Apple TV release, and will be on the most current kicker core firmware.

Updated zwift on appletv, updated firmware on Kickr bike.
U-turn and turns continue to work correct for me. Uninstall/reinstall zwift is what fixed that for me a month ago.
I am still getting some diagonal rider around other riders when it tries to get to the center of the road. If I use the steering to stay on the outsides, it is better.

@Troy_Fox The u-turn bug — just fixed yesterday, after one month of disruption— only appeared once a rider had completed a defined Zwift route. You could always u-turn until that point. What was so pernicious was the fact that people only suffered from the bug at the end of a long route ride, like after their first rep of the Alpe, but wanting to do more.