Can't U-Turn [October 2021] [1.18.0]

I write the results of my tests.

[Test method]
I did a workout at the Volcano circuit.

If you haven’t completed your workout.
Before passing the finish banner.
Change route before passing the finish banner.
[Failure] After passing the finish banner.

If you have completed your workout before arriving at the finish banner.
Before passing the finish banner.
Change route before passing the finish banner.
[Failure] After passing the finish banner.

If you go through the finish banner and complete your workout.
[Failure] Probably all failed.
after about 20 seconds.
after change routes.
After another lap, about 20 seconds later.

If you do a workout, every time you pass the finish banner you will fail a U-turn.
So if you work out and need a U-turn,
You change routes during your workout, or choose a long route that doesn’t reach the finish banner until your workout is complete.

If the test results are the same for the event and the workout,
I don’t think you can make a U-turn after completing a lap course event.

This didn’t work for me. Started Tempus Fugit and did a U turn at 2k and second one after a bit to get back on route. Not the route progress bar did disappear as expected. I then Finished the route, tried and failed a U turn and of course fell into the limited speed defect.
It’s going on 3 weeks sense I reported this and its hard to see a sense of urgency on this significant issue. Very frustrating dealing with a growing list of defects that never get resolved.

Got stung by this on tempus fugit, the annoying thing is that when the issue occured, it then threw me off course and onto titans grove…issue occured at southern end of fuego flats, when I should have looped back around.

Had to quit entirely and restart as I was doing intervals and didn’t want to try hold steady power through titans grove. Can give ride details etc. if required.

I encountered the 24kph speed barrier in a London ride this evening. I wasn’t trying to U-turn though…just hit The Mall and despite having -1% grade and doing 250+ watts my speed was a constant 24…it was like riding through sand!

Combine one wrong turn with app/log in problems with a save button that kicks you out of zwift and you get an irritated rider prematurely ending his session. How about a fix allready

Any update on this?

might be an idea to disable the functionality until it is fixed or at least make people aware when they log in it is very annoying being stuck at 14 MPH for the rest of your ride.


if you will scroll up you will the fix is coming.


in case anyone else is curious:

I still think there should be a message in the companion app or in game when you log in to let you know not to use it for now.


At the end of all my recent rides, I’ve seen people in the chat saying they can’t u-turn. For almost all of them, it’s the first they’ve heard of it. (Because only a tiny fraction of zwifters ever come here.)

Worse, other people are giving bad advice in the chat or conflating this with other issues. What a mess! I really find it indefensible that ZHQ are leaving this to fester for a month.

1 Like

I don’t get why they can’t just disable it quickly and then roll out a fix when they have it


Probably because there is many other things that is linked to the new U-turn module and rolling back will break all of that. That was probably the first thing the programmers thought of doing but due to other constraints it was not possible.

1 Like

yes… this… they have added a Known Issues link to the website chat box which lists the U turn bug and Mac users crashing. This should be on the companion app too.


I wasn’t talking about rolling it back but just stop the down arrow and companion app button doing anything for now.

1 Like

Thanks for pointing that out, Mike. I never use the Zwift website, only the ‘game’ app (iPadOS), and the ZC app. Agree that those known issues should be communicated in ZC.


Hey Mark - I tried ALPDZ repeats using the instructions you gave, it worked perfectly. Thank you!! :+1:



It happened to me while pacing coco. My avatar went the other way and could not make a u turn. - nov6 2021

1 Like

This just happened to me. Not near a banner. Just coming onto desert flats from the forest. U-turn button made avatar start to turn then he straightened and speed became stuck at 24kmph. U-turn button then did nothing at all.

Should this thread not be closed . The issue is known and acknowledged and a release date provided and no change to that is going to happen . The solution that will be put in also is not being surfaced or shared and questions not being entertained , so all that remains now is just to sit and wait for that to be released then we can feedback on that as part of the November 2021 release , positive (hopefully) or not ?

I still find unacceptable that this hasn’t been fixed yet. It’s a trivial bug, its cause is well known and so is the fix.

Hint: if you plan on doing a U-turn, do not complete the route you start on. Most events will complete the route they are set on, the exception being time-based or distance-based events set on routes which are longer than the event. If you go free riding, navigate away from the chosen route before you complete it.

Same issue as everyone else. For me, it seems to happen consistently after finishing a workout. I can be anywhere on any course. The most recent time I was on Tempus Fugit, at the opposite end of the course from the arch and tried to U-turn to join the C group pace partners. I just kept going straight, stuck at no more than 15 mph and ended up on the Sand and Sequoias route until I ended the ride. Any chance of reverting back to a version before 1.18.0?? I’m not sure what problem this was trying to fix. It is getting me ride out doors more!