Can't U-Turn [October 2021] [1.18.0]

Hi Mike, so group rides 2 staturday mornings in a row. I usually complete the SZR ride then do and after party up to 100mile a. Last week did the Uber prezel route 80 mile then carried on in watopia as this was the world I started in. Once I carried on and we all had a 5 min break came back and carried on to 100 mile during that time U-turn did not work and I carried on round in the Jungle as per the way Zwift took me. This week I started in watopia the went to my event in London did the SZR group ride 100km London flat. After it finished I stayed in London for after party to do 100 mile and as we came to the first junction I only had right turn option - rest of group had 2 options and they were going left. I then tried u-turn and didn’t work and was limited to 15mph - gave up. What confused me was the rest of them had the 2 arrows and I only had one never mind the u-turn pain.

Didn’t know this issue until this morning when I attempted my first basecamp. It turned out to be 3 different activities so I gave up after the 3rd up. Hope they fix this soon. :crossed_fingers:t4:

Rode the Pack Sub 2.0 event on London Pretzel, finished the route then switched over to Makuri Farmland Loop where I did my logon. I didn’t attempt a U-turn after The Pretzel but when I got on Farmland, U-turns worked fine. I’ll try it tomorrow by doing a U-turn after the event then switch to the starting world and see what happens.

U-turn after an event is still broken. :face_vomiting: Please fix this. That’s a big bug and not something that doesn’t matter at all.:face_with_symbols_over_mouth: !!!


Scroll up to see the Zwift answer.

I’ve already read that and that’s why I gave my opinion on it. I like to repeat this again. This huge bug must be resolved with the first priority. Thanks.
U-turns sind immer noch nicht möglich nach einem Event Das ist ein Riesenfehler, der sehr vielen Fahrern das Training verdirbt :rage: Nichts mit Fun wie in der Werbung versprochen


J’ai déjà lu ça et c’est pourquoi j’ai donné mon avis là-dessus. J’aime répéter cela encore une fois. La première priorité est de rectifier cette énorme erreur.

Ya lo he leído y por eso di mi opinión al respecto. Me gusta repetir esto de nuevo. La primera prioridad es rectificar este enorme error.

Exactly so. I am in violent agreement with you both. This sht has got to be fixed right the fck now!


A couple o f weeks. Seriously. We get stuck at 14 mph and you can’t take out the u turn bug you implemented that wasn’t really a problem. Plus I’m stuck on a route and can’t turn off of it either.


Mis clicked the u turn button, basically had to end my ride because of it

1 Like

Shortly after the finish banner of the Alpe for me. It happened today and also on Friday.

same…does anyone know how to fix this

I had the same issue. Did a workout, then continued to free ride. I attempted a U-turn but it didn’t work. After that, my max speed was 24 kph.

I think I may have found a workaround for this. I’ve just tested this this morning.

Basically, right after you start the ride, perform a U-turn (once you get into the speed that allows you to do it). Then you may do U-turn once again to get you back to the original direction, if you wish.

Once I did this, everything worked fine. I can select route in intersection, I can do U-turns normally (even close to banner), speed during descent is normal, etc. I did 1h 45m ride without incident.

I think what happened is once you do U-turn like this, this detaches you from your original route selection, and this prevents the portion of the code that has the bug from being executed. Probably the same effect can be achieved by performing manual turn early in the ride, but I didn’t try.

Good luck. :stuck_out_tongue:


Hey @Benny_Prijono
I tested the two U-turn case on LADZ ( see post #118 above with screenshot ) … no joy !
The consensus is to start the Jungle Circuit and make the manual right hand onto LADZ - which works


Tried to u turn after the Tour if Tewit Well ZRL race tonight so I could cool down on a less Hilly course.

My avatar didn’t u-turn, but regardless of watts and decline i was capped at 24km/hr. I tried to get out of it using A to pairing screen, but the cap persisted beyond.

Not a huge deal but a bit of a pain, thankfully I have little reason to u turn usually, but I believe a fix is needed.

3rd day in a row, same problem as others are reporting.

Can’t U-turn on the ALDZ, at the top or bottom. My speed is throttled on decent to 23-24kmph. SORT THIS OUT ZWIFT!

I am planning a vEveresting early next month. If there is no resolution to this issue then I’ll need to use a different platform and cancel my subscription.

If you’re planning on vEveresting before this gets fixed, follow the above^^^^


Thanks Mark. I’ll give this a go on Friday when I’ll attempt a x2 repeats of ALPDZ :+1:

1 Like