Can't U-Turn [October 2021] [1.18.0]

Thanks for the tip. I did try holding it down with no result. Ugh… at least it works on the main screen using the AppleTv remote. Just easier to use the companion app. We’ll see what Zwift comes up with since there are apparently others with similar issues. Thanks again

Ditto, not impressed whatsoever :rage:

1 Like

I had this glitch early this morning (ATV4k), just retested an hour ago and seems to be working now.

I had the same issue yesterday and today, after crossing Alpe de Zwift banner, not able to U-turn and also stuck at 23-24 km/hr.

Mine wouldn’t work through companion app, or using the down arrow on my keyboard, or goin through the in-game on screen menu either. I’m on an iMac

Glad they’re taking care of it. I may have used some
Harsh words yesterday but just annoying when things are not working

I have see the no U-Turn problem three times since the update. All appear to be related to either an event or riding with a pacer.

After leaving the event, or leaving the pacer, U-Turn would not work. Either using down arrow on the keyboard or bringing up the screen menu and clicking on the U-Turn icon.

1 Like

I’m on Windows 10 and encountered the same bug. Zwift app is 1.18.0.

During a custom workout I decided to make a U-turn and hit the down arrow key. My avatar didn’t turn but slowed down to 24kph (15mph) tops, whether on the flat or the descend.

I tried to quit the workout from ZC app running on my phone but couldn’t. So instead, I quit the ride from the Zwift app, and started another workout without exiting the app, then all of a sudden, my avatar made a U-turn without me doing anything this time.

1 Like

Just finished BMTR Short Adventure group ride. After that i was continued my own free ride and testing u-turn and it worked. Then i finished that ride and start new ride and testing u-turn again, it worked.

1 Like

Question for you all: when you made the u-turn, were you near a finish banner? Or was it a random turn in the middle of the course?

Exactly same behavior here…
Yesterday after 1.18 update on a Mac, the ‘A’ button to open the pairing screen did not stop the avatar.
It kept moving. I didn’t hit the U Turn button yesterday.

After today’s update 1.18.1 when hitting ‘A’ button and opening the pairing screen stops the avatar as expected. But U turn does NOT work, either on the Zwift application nor on the Companion App.

I climbed the Alpe du Zwift and went down after without issues.
I rode for 40 Kms without a single issue. I was able to select route navigation direction options without issues, and the speed of my rider seemed ok as always.
Then at some point I hit the U Turn button and it didn’t work. Tried with the keyboard, the button in the Zwift application and in the Companion App. No way to get it to work.

And after hitting the U Turn button, everything started going wrong…
Route navigation directions were totally ignored. No matter what I selected, the avatar would go wherever it wanted.
The speed of my rider was totally off. I was pushing 2.7 w/kg on a -6% descent and the speed was 18 km/h… People doing 1.2 w/kg would pass my like airplanes.
Even saw a rider supertucking UP de Alpe du Zwift! He was going up without pedaling at 70 km/h on supertuck position!.

It was a random U Turn attempt in the middle of a course while free riding.
Saw a friend and tried to join her.
Hope this helps.

Completely random position.

On a free ride.

1 Like

Mine was near of finish banner.


On second lap of “Sand and Sequoias” just entering the sequoias section. No U and max speed was locked too from then on

1 Like

Last 2 DAYS up Ventoux, after finish tried a U turn to go down …no go…just kept riding in a circle around the top of Ventoux…the U turn icon on bar was no longer there as an option at the top…

1 Like

I actually tried to make a turn right on a finish banner , within meters , didnt happen ( post event too ) … i didnt want to cross it and mess up my segment time :rofl:

1 Like

In a workout, tried to U-turn but it did not work. Kept going but speed was locked at 24 km/h. Using Apple TV HD.


I have seen it both at banners and random location.


Zwift PC Version: 1.0.85684
Same here: Tried the U Turn at the banner which didn’t work.
Downhill max speed 24 km/h.

Havent logged in since Thursday but this max downhill speed is being reported by all my club users .
This release seems to have plumbed new depths of bug problems . Will be using another platform until it is sorted out . This release needs rolling back surely.,

1 Like