Can't pair both Power and Controllable signals separately [August 2021] [1.16.0]

What is so difficult about logging the config (ANT+ id and unique identifiers) on a .config file and then have the system read from it and prioritize pairing to those devices?

This is literally intern-tier programming. I was gonna be “nice” until I read the “it’s not going to be in November/December” rhetoric.

EDIT: lol even your forum code is buggy as heck, I had to edit out a multi quote bug.

Ive not had to play about with the pairing in a good while but considering run dual apps again (TR alongside Zwift) and I would want to ride one ride with the source as controllable trainer, next ride, same source but only power.

is that going to be possible or is this now broke?

@Lee_H You should currently be able to ride with either power + controllable or with just power. In the future, you will continue to be able to ride with either power + controllable or with just power.

It requires changing the settings in the Pairing Screen, though, before each ride.

To ride with controllable trainer only, you currently must pair Power first. Then pair Controllable (once available), then un-pair Power. In the future you will toggle the use of Power meter on/off and the use of Controllable trainer on/off.

3 Likes

Hi. Been off Zwift for a few months due to injury. Back on it now and update was required which ‘blew up’ my trust old laptop. Using iPad and lost controllable too. Has there been a fix to this issue. I run bkool and had used ant+. Got an adapter for iPad Air to attach ant+ but still no controllable option. I get power/cadence and had to buy a wahoo hrm as wouldn’t fine my garmin hrm. I need help :weary:
0

This happens to me with the latest version on Windows. Tacx NEO 2T (purchased from Zwift) will connect with power and cadence but not controllable. I have to fuss with the settings for amount a half hour each time I ride, rebooting, turning power to the trainer on/off, restarting Zwift, deleting my known devices file. Exentually it works but I’m meanwhile irked that I missed my ride EVERY DAY due to this. Could you please fix your program so it does the basics, like connect to devices?

This thread is about using separate devices for power but it sounds like you’re just wanting to use your Neo for all signals - power, cadence and controllable, which shouldn’t be an issue. Are you using ANT+ or Bluetooth?

Bluetooth. Basically it’s a hot mess and everytime we start Zwift we need to fuss with it for several minutes. Total pain.

Why can’t it just lock to what I used last? And only search just if I want to add something new? It always wants to connect to my wife’s bike, my pedal power meter, or the ANT output on our bikes instead of Bluetooth.

Hi @Tim_im.Eckel_TAB and @catherine_lyons_c

The Bluetooth Controllable signal typically takes about 10 - 15 seconds to become discoverable.

  1. Pair to the Power signal first
  2. Click on the Controllable icon and wait ~10 seconds. Does it show up, or not at all?

If you’re using a computer with an ANT+ USB dongle - ANT+ signals tend to be discoverable quicker. Not sure why that is TBH.