Can't pair both Controllable and Power signals separately [1.15.0] [July 2021] [SOLVED]

Those of you having problems still:

  1. You may need to pair your devices again, and the settings should stick this time. If it does not - you may want to try resetting your game preferences

  2. Now that you’ve reset -pair to the Power signal first.
    Then pair to the Controllable signal. It may take 10 - 15 seconds for the controllable signal to appear.

I did everything above with the reset and even deleted and re installed Zwift multiple times in my iPad. The trainer is still not popping up on my controllable section

Running iOS with Assioma pedals and an elite direto trainer

Hi @Bekim_Haliti

I looked at your recent session history and I’m seeing an iPhone and an iPad both logged in simultaneously. I imagine that you’re testing both, but this creates problems.

If you’re already logged in on the iPhone and it’s paired to the trainer, then the trainer’s Bluetooth signal is not available when you fire up the iPad. It’s possible that’s what’s going of for you. Best practice is to only install Zwift on the device you intend to use.

I also don’t see a Log Out event on the server. After you’re done riding/running, log out of the session by saving & uploading (or saving & trashing). Simply swiping the app into the background is not the same as logging out properly.

I logged into the iPhone immediately after to see if it could pick up the trainer. It was not showing up on either.

After my ride, I turned off my phone and put it outside just to make sure there would be no interference. I went back to the trainer with just the iPad and the trainer is not showing up still. I have no clue what to do at this point. Is there a customer support number with someone that can troubleshoot with me? I’m pretty technologically adept and have followed all the steps laid out in this thread but nothing has worked.

Hi @shooj - tried this but still seem to have to connect my PM the long winded way (ie connect trainer as power source and controllable before coming back to reselect PM as power source).

I still think the bug is not 100% fixed as I still cant connect my PM as power source directly as the trainer will not show up under controllable if I do that (even after waiting a minute +). Tried reinstalling but didnt work also…

Be good if you could bring it up with your technical team to check if there are still small bugs around.



you introduced the ‘cause’ with an “update” a few months ago, surely you know what you did, and can fix it ?

Hi Shuji - Thank you and Zwfit team.

My Zwift app was updated and it works (by additional steps, please see below).

  • Equipment: iPad pro + Kickr5 + Quarq (all software/firmware updated).
  • Game preferences reset (by deleting and reinstalling Zwift app on my iPad)
  • tried waiting 10 - 15 seconds for the controllable signal to appear but fail (see below).

My first priority is Quarq as power meter and Kicir as controllable.
1- Both Kickr and Quarq appeared in power meter; choose Quarq.
2- Kickr not appeared at either cadence and controllable, even hold over 1 minute. Quarq appeared at cadence.
3- Re-select power meter as Kickr.
4- Quarq not appeared at cadence. Kickr appeared at both cadence and controllable.
5- Set Kickr as controllable. By this configuration ride could be started and Zwift works nicely as usual.
6- Re-select power meter again, as Quarq this time.
7- Now both Quarq and Kickr appear at cadence, and Kickr appear at controllable. Choose Kickr as controllable and Quarq as cadence, then ride on.

Step 1 - 2 are not necessary, and step 3 - 5 are additional steps.
Hope this helps.

The bug is back to the May “update”. NOT SOLVED

The workaround is to select the controllable trainer as power, then reset swift to you power source.
Selecting power source first gives does not give a controllable trainer, even after a long wait.
(If you then restart swift it defaults to power source and no controllable trainer !)

Let’s hope the next update ala June, does not again prevent the workaround working !

Apple TV, companion app on iPhone. Kinetic control BT trainer, Garmin V3s power Pedal

Please do not consider this “fixed”. After I went through the dance of uninstalling the app, reinstalling the app, I still had to do another round or two, of select X for power, then Y for controllable, then Y for cadence, than change… WHATEVER!!!.. finally slapped things around enough to get the right combination. This is “progress” in that now I can eventually get what I need, but requiring reinstalls, setting, resetting devices, etc. is NOT a “fix”. That’s just not how this needs to work (and not how it did work until recently)

1 Like

I am still having an issue with the Elite Direto. I have deleted and re-downloaded the app multiple times now on both my iPhone and iPad. My trainer is still not showing up as a controllable option. I then tried using my computer to see if that would be the issue, but the Elite Direto is still not showing up. I thought there was an issue with the trainer, but I am able to use the Elite as intended on the Elite App and TrainerRoad. I have no idea if there was some sort of glitch that has removed the Elite Direto as an option, but I am now out of options and no one from Zwift is responding to the issue anymore after it was considered “fixed”

Same issue here, since the update, my iPad cannot connect to my cranks power meter and my Snap at the same time, so I cannot use my crank as a cadence sensor.

For me to get the cadence to work I have to use the crank power meter as the power source, not the trainer, but then I cant use the trainer for anything.

I have tried all steps told to us, uninstall, reinstall, clearing files etc, nothing, it does not work.

This is 100% not fixed.

This is still not fixed. Forums are littered with people with this issue, its 100% not fixed.

1 Like

@shooj - I wanted to check if Zwift is still working on a fix for this bug? as many of us have mentioned its not 100% fixed yet it’ll be good if we could get an update from your team.


Correct, I spoke too soon - not fixed. Plus, sensors randomly drop their connection when I am fortunate with the workaround mentioned above.

Not fixed - resolution does not work for my kickr bike and Max on big sur

Not sure if the team is following this but I’m running a Mac with the latest update on Big Sur, riding a kickr Bike with the latest software on it.
I have uninstalled zwift, renamed my Zwift directory and re-installed Zwift app
The Controllable section never shows the bluetooth connection, the powermeter does, but when I connect the powermeter to the bluetooth connection I still do not have steering. For some reason, the Controllable does NOT ever see the bluetooth therefore the steering is not available on my Kickr Bike.

Are you guys investigating this issue? @shooj

Also note, I did wait over 30 secs (I’m familiar that Bluetooth takes more time) for Bluetooth to show up on Controllale - it never did @shooj

An additional issue for me that’s related to the controllable pairing. My sensors lose connection repeatedly with Zwift. This last 2h workout I experienced at minimum 30 sensor drops. Here’s what happens:

  • vast majority of sensor drops happen in the first half of the ride
  • cadence sensor loses contact first, often regains contact immediately, but often not
  • when cadence sensor drops for more than a second, Zwift loses contact with the power sensor too
  • in all cases, my Stages crank arm is the PM and cadence sensor, Kickr is controllable
  • issue identified at the same time when the buggy update was released
  • issue seems to be occurring more frequently as time goes by
  • issue is obviously causing significant data file inaccuracies
  • issue is not related to the sensors themselves, my garmin watch holds the connection just fine

Please advise! This is truly maddening when your avatar stops pedaling and unclips in the midst of an interval as you are pedaling away with unchanged power or cadence.

Folks, we’re seeing symptoms similar to this in v 1.16.0 that released today. We’re thinking there’s two paths to investigate a bug that we thought we’d squashed. If you’re having these issues, please join us on the August 2021 thread affecting v1.16.0.

I’m going to close this thread to move conversation over there.