Can't pair both Controllable and Power signals separately [1.15.0] [July 2021] [SOLVED]

Same problem with magene t100. I thought my trainer was broken. I can connect it to my magene app though. Fix this please

1 Like

Does anyone know how to log this issue?

Zwift is now essentially useless to me - I have a wheel on trainer which measures power absurdly high so I am utterly reliant on my power meter for power data and the trainer for resistance.


I have the same problem after the update with my iPad - Using QUARK SRAM as powermeter -

1 Like

Same issue for me :frowning:

Same issue

Prior to the latest update I was able to select my Smart trainer as both “Power Source” and “Controllable” and then change the “Power Source” to my Power pedals and have the my smart trainer remain connected to the “Controllable” . But now it seems I can only connect to either one of the “Power Sources” but not both. I’m doing this on my iPad.

Anyone else having the same issue?

yes but only on my apple TV, iphone is fine.
the problem : Dropbox - IMG_3275.MOV - Simplify your life


I’m having the exact same issue on my iPad. Used to follow the same process - pair Kickr as power source and controllable, then change power source to my crank power meter. Now this doesn’t work.


I have to do this on android and pc too when using bluetooth.

pair the trainer as power to get it to show up as controllable trainer then de-select it as power and connect the power meter.

This still works on android (as of yesterday) haven’t tried PC since the last update so can’t say if it does or not on that but seems like an iOS/Apple issue.

1 Like

Glad to know I’m not the only one. I have reached out to Zwift tech support and they are looking in to it.


yup. ipad Pro - zwift normally setup with power meter for power/cadence and kickr for connection (dual power recording on the other side with ant etc, most reliable connections on the ipad.)

first zwift session for a week and can’t do this. whatever is selected for power must be the trainer control connection - that’s the kickr. can’t then change the power/cadence source without the
kickr control connection being dropped.

fortunately the Mac version doesn’t have this issue and that’s how today’s ride was done. hope this is fixed soon as races are much better on the ipad pro (no M1 mac version yet….)


Glad to find out that I am not the only one with the issue. It is confirmed that it’s the issue on Zwift App on iOS after the update. Prior to this update, i can sync both my Power meter and Smart Trainer (i am using Gravat 2) simultaneously. Just to share, below are the scenarios I have tried:

  1. iPad 8th Gen and iPhone 10 Plus - only works either connecting to Power Meter (Assioma) or Gravat 2.

  2. Same iOS device as above, running it on Traineroad. Works perfectly. Again, these prove that there is no issue with my hardware.

  3. Samsung Note 10 - works fine connecting Assioma as Power Source and Gravat 2 as Controllable.

  4. Windows - Works just fine.

Summary: it’s the issue with Zwift App on iOS platform.


Thanks for confirming as well!

Please note I have been in touch with Zwift tech support and they are aware of the issue and working on a solution, though no time frame for a fix, but hopefully soon!


Thanks for getting in touch with tech support - I wasn’t sure what to do other than posting on here! I’ve had to bring my work MacBook into my garage for workouts but hope I can go back to using the iPad soon.


Good to know other iPad users are having the same issue and support are looking into it. The app totally crashed on me then I couldn’t connect the kickr and vectors. I asked the chatbot but it kept sending me to articles about pairing issues. There’s nothing as frustrating when you are in a race and adrenaline is flying and this happens. Anyone have an email for support so they can log my issue too. The chatbot refuses to link me to a human :frowning:


I’m having the issue since updating the iPad app last week too. It’s my Assioma pedals, or wahoo kickr and no way to even use the Assioma cadence if wanting the kickr to be paired as a controllable trainer.

To all those who have the problem or posted, don’t forget to upvote this topic!


I’m having this problem too, on Apple TV.

Can’t have controllable trainer & power meter connected at the same time :frowning:

Everything worked perfectly until recently.


As of today, I am still having this issue. Prior to the last update I was using Rotor PM for power and cadence and Wahoo kickr for controllable. Now I’m only able to use Kickr for all three or I cannot use erg mode.

I have yet to try controlling the Kickr with Ant+ power meter(via the wahoo iOS app) I’ll report back my results after trying.


Also have this issue. Apple iPad Pro, Elite Suito, Spesh Power cranks.

Really quite tired of how often fundamental stuff gets borked in an update. It’s not free software, but it doesn’t half feel like it sometimes.


Also had this issue on my iPad Air 3 with my Favero Assioma Duo PM pedals and Elite Qubo Smart B+ Trainer. Raised this with tech support who gave the same response as others have mentioned. They also directed me to this thread so at least they are listening!