Can't Load world since update

Since the update in November, I can’t load anyworld. I’m able to start the app, pair my devices, but as soon as I try to ride a route, the app hangs and won’t load.
I run an Core i5-8250U @ 1.60GHz, with a Intel UHD Graphics 620.
Please note, I have not had an issue until the upgrade

What version of Zwift are you on? What OS on your PC?

I’m using the most recent version of Zwift version 1.19.1 (1.0.100133) , and Windows 10

I never had an issue using zwift until this update.

Several people have been reporting this since the last update. I’m not sure that there’s a single thread on the issue.

Thanks, it’s frustrating but I’m sure they will figure it out

I’m having the same problem. Tried restarting zwift, restarting the pc and uninstalling and reinstalling zwift, still no luck. Running the latest version of zwift on windows 10. Very annoying not being able to train at all.

HI Katherine, I managed to resolve my issue by upgrading the firmware on my graphics card. You should give this a try.

Frank