can't link to Strava


(DB Smith (65+)) #1

Not a great start: Just downloaded Zwift and used the “connect to Strava” button to set up my account.

Every time I entered THE CORRECT user name and password for Strava, Zwift just kicked it back.

My ANT key comes via Amazon tomorrow and I’ll try a ride or two.

But IMO Zwift isn’t off to a good start (with me, anyway).


(Michael Henasey) #2

perhaps you should open a support ticket to resolve your issue.


(DB Smith (65+)) #3

I immediately went to “support” and was directed to the ‘knowledge base’. There was no entry (of about 5-6) that spoke to my issue.

I didn’t see any way to ‘open a support ticket’.

It may be there but it certainly wasn’t obvious.

As I said, Zwift isn’t off to a good start (with me).


(Michael Henasey) #4

At the bottom of the Support site is a button and link for Submitting a support ticket. Give that a try :slight_smile:

https://support.zwift.com/hc/en-us


(Craig Hoskin) #5

@Dana, you can be excused … the submitting of a ticket is one of the best hidden aspects of the ZWIFT website :slight_smile:


(DB Smith (65+)) #6

Got it. Problem was limited cookie access. I typically use Ghostery, AdBlock and limited cookie permissions; had to disable/change a lot. But now it’s linked and working ok.


(Joy Nix) #7

Hi new to Zwift and purchased two subscriptions but cant link to Strava. Followed the link button but only get a dot that pulsates. Tried it on the iPad safari and on my Apple Mac. all show the same for both me and my wife. Any ideas??? Help! Graham


(DB Smith (65+)) #8

@Joy Nix

I had this just the other day and Support guy said he’d not seen it before:

Fix for me was to use a different browser to log into Zwift and Strava – I’ve always used Safari on Mac and got the pulsing orange blob you describe – but switching to Chrome, which I’ve never used with either Zwift or Strava, solved the issue; I was able to successfully link to Strava.

Doesn’t make a lot of sense but it worked. I’d tried several other things – clearing cookies, killing ad blockers, etc in Safari before trying Chrome.


(Michael Henasey) #9

Recent known issue. Zwift blogged about it. Use Chrime or other browser as workaround until fixed.


(Ryan Chaney) #10

Still fails both on Safari and Chrome. REALLY annoying.