Can't launch Zwift after v 1.25.0 game update [macOS]

It’s not working on either of my Macs. I saw that “extra update” window after I restarted my Mac, but it went away, and still nothing launches.


Hi @Iain_Collings welcome to Zwift forums.
Appreciate you weighing in with your experience. I assume that when the dialog box to apply a quick update came up - you did say yes to the update?

When you did - what happened next? Did the launcher app keep showing you different slides like the AAPI Heritage Month image? Did it hang on one image? Did it go away completely?

@shooj @Iain_Collings
It took several relaunches before the dialog box stayed open long enough for me to press the OK button.

The problem was that when I moved the main window to try to find the “extra update window” I moved it down. I didn’t realise it, but that caused the window to be minimised, which made it look like it was either crashing, or going off to do the update. Actually it killed the program. I finally worked out that I had to restart the computer in order to get it to show the “extra update” window again. Then I moved the main window sideways, and it worked. The bummer is that it then said my OS is out of date and Zwift won’t run after August 1st. The computer’s 7 years old and Apple have stopped supporting OS updates. I guess I need a new computer now. :cry:

Thank you for reporting back and letting us know what happened. Sounds like you were able to update both the launcher app and the game app and log in successfully?

You do have until August 1 to use your current Mac. As Zwift runs on iOS / Apple TV / Windows / Android in addition to macOS - many Zwifters will already own a more suitable device to run the game.

For everyone on macOS who can’t log in, here’s the workaround for this dialog box awkwardness:

  1. Download the latest game app + launcher app bundle from
  2. Manually install this package.
  3. Restart your mac and start Zwift .
1 Like

I CAN log in. But Zwift freezes (scrolls thru the notifications, like AAPI Month) after the “Let’s Go” screen. No dialogue box behind it.

What’s the fix for that?

Mac OS 11.6.4.

1 Like

P-Sauve try restarting the computer. After I did that, the “extra window” appeared.


Restarting the computer solve the problem for me.

1 Like

Thanks Iain!

Restart, Relaunch, then that dialogue box also appears, the quick Update, and working. Closed, and works as expected the 2nd time through.

1 Like

Yep that was the case for me. That pop-up window was hiding behind all of my other windows. Mac OS 12.3.1

The dialog box was hiding behind all other windows. Found it, allowed the update to happen, and the launcher is now working fine. I’m on Mac OS 12.1

Arrrgh. It’s just the small window s Scrolling sideways. Arrived 25 minutes early and missed my group ride. A pox on this update

Edit: worked after reboot

And delete all the file in ~/Library/Application Support/Zwift and muck around with the files in Documents/Zwift and then restart and download the installer repeatedly until you get the one that actually updates.

It’s clear no one tests this stuff before release. #worksforme seems to be the sign-off criteria. I really look forward to riding when I get home from work and trying to figure out the new UI is enough for one week. I lost about half an hour yesterday with pairing issues but that’s not new, almost expected. Now this. Pathetic.

1 Like

I’m experiencing the same problem, I saw the dialog box but then disappeared quickly, now Zwift is not starting.
MacPro Late 2013 (MacOS 10.14.6 Mojave)

Was this after deleting and reinstalling Zwift?

This was certainly the issue I had – tried reinstalling etc. Only when I came to do a complete shut down did I see the hidden screen. Reinstalled - found the hidden screen and now okay ! Well as okay as it ever is !!

That little dialogue asking to install something is very elusive.

The first time was nowhere to be seen. Kill and try again.
The second time I saw it briefly before it disappeared but I could not find it again whatever I did.
The third time it worked as it was supposed to.

1 Like

Glad I saw this before I updated. Waited for the popup and was able to keep it going. it usually takes a minute or two for updates on my wifi but I did have this experience today which was mildly funny …
I had to restart the update and all was fine.

1 Like