Can't download an activity


(Mark Croonen) #1

I just finished a ride and it shows up on my Zwift dashboard however unlike the other rides there is no download like below it. Also the ride didn’t sync with Strava so I have no way of accessing the ride data.

Not sure if anything can be done but maybe a problem there worth looking at.


(Jon Mayfield) #2

In your Documents/Zwift/Activities folder there may at least be a .fit file for your activity.   Can you let me know if one is in there?   If there is, does it work if you manually upload it to Strava?


(Mark Croonen) #3

No there isn’t but it’s a little more complicated than that. On the weekend I upgraded to Windows 10 which broke the link to my documents folder which was being stored on a NAS (a separate issue of the NAS name not resolving on W10). Although W10 appears to have recreated a documents folder for me on the local drive, there is no zwift folder in the new documents folder.


(Jon Mayfield) #4

Ah, that explains it then.  Both the auto-upload to strava and the upload to the zwift servers come from the file that is created in Documents/Zwift/Activities.  If that folder cannot be created the activity file won’t be uploaded.  


(Mark Croonen) #5

Bugger I guess that means my ride data is no more :frowning: Oh well it was a pretty crappy effort, best forgotten anyway

Still interesting that Zwift didn’t try to create a new folder in the newly created documents folder.

Of course it is odd that it got to the zwift dashboard but not Strava, which makes me think it must be lurking on the the local drive somewhere. Think I might go fit file hunting.

 


(Jon Mayfield) #6

What you see on the site is summary data, which is simply stored in memory. All the details are written to the disk in a fit file.  Zwift does try and re-create that folder every time it runs, however something must be wrong with a setting somewhere.  We ask the OS where your documents folder is and simply use that path.  Either Windows 10 has broken that (which I’ve not experienced myself, but I’ve not tried the latest build of W10) or that part of your configuration is wrong somehow. 


(Mark Croonen) #7

Well thanks for the help and the info.

I guess if I will use a beta app on a beta OS you kinda have to expect something might go wrong :slight_smile: living life on the edge


(Rob Toeppner) #8

I’m not seeing this on build 10122 if that helps any.

Also, if you run Zwift as administrator, does that make a difference?


(F atty-Roo RO4H) #9

Same here.  I’m using the ios version on my ipad and last week’s London and today’s Watopia rides won’t download.  I checked the folder on my ipad and there are 3 fit files.  

 

I ran them thru FIT File Tools to get the elevation corrected then uploaded to GarminConnect however the second 2 files all reported as the same activity, the Richmond ride.  Nothing for the Watopia ride.

Hope this is resolved soon.

Thanks for a great site and app.  Loving it.

Cheers

 

 


(Adam Papai | WoOh) #10

I have a similar issue. On iPad I have a 0 byte file only nothing else. ;/ I hope they’ll fix it soon.


(Dam Cortès) #11

Hello,

Similar issue, I am on iPhone 6s plus and I olny see the distance and time but can not download the file and it is not send to Strava. Last week it was working perfectly.

Thanks for your help :slight_smile: