Cant control ride with Zwift Link. I dont get the controls

I have tried quite a lot to get solve my problem but to no avail.

I have a Tacx Flux. I use my PC to ride on Zwift. I have an antenna that connects my Tacx to PC via ANT+.

I have Zwift Link verson 2.1.9 (329) running on my iPhone running the latest iOS.

My PC and iPhone are on the same Wifi network. Just to be sure, my phone is on airplane mode only connect via Wifi.

My Zwift on PC and Mobile Link on phone both have the same account logged into.

I start Zwift first, then I start Mobile Link. Whenever I start any ride/workout, although Zwift Link does tell me that I am riding right now showing me distance/power etc but it does not display me any controls. None what so ever.

 

Any step that I might have missed ? 

Is it displaying the map? The map screen is the default screen on the ZML.

Also a firewall on your PC could make it difficult for the 2 to connect, you could try disabling it.

I always start the ZML first and then start the Zwift app on my PC.

Thanks Paul for the reply. When I start ZML, the default screen is :

The same screen appears  when Im riding. Under activities it will be telling me my current ride stats. I see no maps unfortunately. 

Hi again Paul. Thankfully I paid attention to your “Also a firewall on your PC could make it difficult for the 2 to connect, you could try disabling it.” comment. I use my corporate laptop so it has some weird builtin firewalls. I disabled it and woala ! 

Thanks !!!