Cant connect to Strava


(Kristian RCC AMS 0304) #1

Dear all,

since i had troubles with the auto upload to Strava after the new software update of zwift I decided to disconnect from my strava account and reconnect again. 

This is where the problem starts, after giving authorization in the Strava splash screen it goes back to zwift and it just “hangs”. Refreshing the page results in that strava button indicates + to connect…,

hoping you guys could help,


(Bastiaan Gaillard [HIK - C]) #2

Maybe you should revoke access in Strava as well and try again:

https://www.strava.com/settings/apps


(Kristian RCC AMS 0304) #3

Hi Bastiaan, thanks for the tip, but unforunately there is nothing to revoke since its not listed anymore in the app section.
What to do?


(Bastiaan Gaillard [HIK - C]) #4

Hi Kristian,

I have just tried using a Chrome browser. Disconnect the Strava connection from my Zwift profile. It disappeared in Strava so you are right about that.

After that, I reconnect again with success. So the whole procedure works…

Can you try using another browser?


(Kristian RCC AMS 0304) #5

Hi Bastiaan, since im working purely with OSX devices at home i tried you’re gesture at the office. With positive result! Strava has been reconnected again and auto upload functioning again! Many thanks for your help!