Cannot login 1 day after paying for membership

Dear all,

I did the trial for 1 week and had no issues. Then 2 days ago I payed for the membersship and Zwift wont let me log in anymore.

It says either 2 things:

  • Failed to log in. Check internet connection.

  • Logged in but there are no roads to ride.

Now the first 2 days from my payed membership are already to crap.

Anything that can be done?


There could be a routing issue with your ISP that is causing this.

What you can do is restart your modem, router and Zwift device and see if that helps.

A VPN could also help in resolving this issue.

Over the last couple of months users in Europe have been experiencing random issues connecting to the Zwift server dues to some routing issues.

1 Like

Restarting my pc / modem doesnt work.

Yesterday it worked after 2 hours after i did my workout with the Tacxapp…

And it also works when i make a new account…

Surprisingly strange

Now it works after 1,5hour trying and restarting PC/ modem.

I hope Zwift can solve this issue soon as i cannot afford every day to loose 1,5 hours only to start Zwift.

It’s not a Zwift server issue, it’s an issue with some ISP’s and how they are routing traffic. I have seen this over and over again during the lock down period. Germany had a issue for about a week, a lot of European countries had an issue last week and a week before that I think there were issues in SWA.

Here is a link to Zwift Server Status: