Cannot find rider with that Zwift ID

EDIT - Solved! Put in the wrong ID. D’oh. Wrote it down incorrectly.
I keep getting an error message connecting with Zwift Power: Cannot find rider with that Zwift ID. Zwift power was connected in the past, and when I went to the my.zwift page it showed it was opted in already. I also tried opting out and opting back in. Any suggestions?

Zwiftpower is saying you are not registered there. Have you gone through the ZP registration process (changed your name with ID at end etc)?

I have a log in - isn’t that what it should take to be registered? I added a team name to my Zwift name a few weeks ago - would that affect it?

Hey Dean, I think what you’re asking there is what I was trying to do when I got that error message. It required putting in a Zwift ID. When I put my Zwift number in (next to the green box) that’s when I received the error.

Hey Dean, thanks for responding. See edit above - had wrong ID number written down.

1 Like

Thats great news Rick, glad you got it sorted!!