Can i use Garmin 735xt (watch) on wrist heart rate with Zwift?


(Jason Nubeebuckus) #1

Hi.  I have a Tacx Flow T2240 Smart Turbo Trainer and a Garmin 735xt watch.

Zwift pairs the Tacx OK (power source, cadence, controllable trainer)

 

But i can’t seem to use the Heart rate monitor on the watch (even if i start an activity).  I guess it’s not broadcasting the heartrate via ANT+, and i need to buy a separate heart rate monitor to pair to Zwift?  (then manually import .FIT file to Garmin Connect)


(Bastiaan Gaillard [HIK - C]) #2

Must be possible. Maybe you’ll need a firmware upgrade. Check this post from DC Rainmaker:

https://www.dcrainmaker.com/2016/06/garmin-forerunner-735xt-in-depth-review.html


(Amy - ATC) #3

I just paired mine. Go into Settings, Heart Rate Monitor, Broadcast Heart Rate, set it to Auto if it is off. That did it for me. I also have the latest firmware, but that is supposed to be required only to broadcast while in an activity. Ride on.


(Jason Nubeebuckus) #4

Thanks Amy, worked great :slight_smile:


(Adrian Ng) #5

Sorry for the newbie question…but when you guys connected your 735xt is it on a computer?? 

I tried to broadcast my heart rate from my 735xt on my iPad…however it just keeps searching without finding my garmin :( 

Any help would be appreciated. 

Thanks :slight_smile:


(Amy - ATC) #6

Yes. I think the 735 may broadcast in ant+ so you would need an ant+ dongle for your iPad, I used to do this with the 920 and Mio Link before I got the 735. Now I just use my computer. It seems like there might be a link somewhere on the Strava equipment page for the dongle and I think it plugs into the charging port.


(F atty-Roo RO4H) #7

I have mine broadcasting the HR to Zwift thru Ant.  The BPM is picked up fine.  However, it seems to corrupt the firmware or USB drivers on the watch.

I reset the watch to factory defaults, load up all my profiles again, etc etc.  I then go and ride on Zwift with the HR being broadcasted.

I then connect the watch to my PC’s either Win7 or Win10 and the PC’s cannot find the watch.    The USB charging screen displays on the watch.  When I remove the watch from the cable, the charging screen remains and I have to do a hard reset.

I’ve had to do this 4 times now even though Garmin says its being I downloaded Garmin Express thru Google Chrome !!!

Garmin IT today said that it may be the Zwift app that is receiving the HR is, somehow, corrupting the watch.

I’ll raise a ticket with Zwift support