Calibration ruining everything!!


(Bob Beckley (KokoDog)) #41

Calibration of Cycleops Hammer trainer

These steps worked for me.  I have a PC laptop computer running Zwift, plus an Apple iPhone running Zwift Mobile app, with a CycleOps Hammer trainer.  I have an ANT+ dongle on an extension from the PC to the trainer.

This adds to notes given by T Rock- T Rex.  Thanks for your help!

Do NOT calibrate it in Zwift-- calibration does not work for the Hammer in Zwift.

  1. Powertap : Update the Cycleops Hammer firmware:
  • Made sure the Cycleops trainer is awake (pedal it).
  • Make sure you do not have Zwift or Zwift Mobile up.  If so, end them so they are not connected to the trainer
  • Open Powertap on iPhone
    • Select Update Firmware from the menu.
    • If you have the latest, it shows no update needed.
  1. ZWIFT : Warm up (DO NOT CALIBRATE IN ZWIFT):
  • To make a Hot calibration, ride around in ZWIFT for 10-20 minutes
  • After 10-20 minutes of riding in Zwift, close it:
    • Click the A key (pairing screen) and unpair the trainer. 
    • Or, you can exit the app altogether.
  • If you have Zwift Mobile running on your smartphone, terminate it.  You may need to go into your phones multitasking windows to end this app.  Or just shut the phone down to terminate its connection. 
  • This should end all software connections to the trainer
  1. Rouvy: Calibrate Cycleops trainer
  • On the computer that Zwift runs on, make sure you have a Cyclops BlueGiga USB dongle (purchased as the CycleOps Shop) in one of the USB ports.  This is needed to communicate with Rouvy.  When riding in Zwift, I have an ANT+ dongle to my trainer.  For this calibration, I leave the ANT+ dongle attached and just plug in the additional BlueGiga dongle.
  • Open Rouvy on the computer (same one that Zwift is on).
  • In Rouvy, go to Settings and make sure you have Cycleops Hammer and your sensors connected. 
  • Go to Free Ride.  On the top right, click Calibrate Trainer�.
  • It asked me to ride to 20-25 MPH. If you pedal too fast, you have to start over.  Once I pedaled in that range, after 20 seconds, I could feel Rouvy controlling the trainer, it got really easy to maintain 25 mph - almost no pressure on the pedals. Then it said stop pedaling… It never stopped spinning totally but it came back and said calibration successful and spin down time was like 21.9 seconds.
  • End the Rouvy app to disconnect it from the trainer.  Remove the BlueGiga dongle.
  1. ZWIFT : Go ride.
  • Start Zwift Mobile on your smartphone and let it connect
  • Go back to the Zwift pairing screen on your computer (or restart Zwift on the computer) and select to pair with the CycleOps Hammer again.
  • You can now return to riding with your new calibration setting.  Calibration with the Hammer should be good for a month.

(Christopher Stewart) #42

I just updated to Cycleops Magnus 31.042, released January 31 2018. I did a Zwift calibration and then was able to hand-turn the cranks one-and-a-half times. The power reading shot to 2000 Watts. Do not calibrate the Cycleops Magnus in Zwift.

Rouvy calibration does… something, but I don’t know whether to trust that, either. It is perhaps correct but it does not match up with the factory calibration. Watt readings are way lower, which probably means that the factory settings were just bad. But these newly calibrated readings are also lower than watt readings I could maintain on a Keiser stationary spinning bike at our company’s fitness center. That Keiser bike might have been wrong also, but it is at least a basis for comparison. I’m thinking of getting an actual power meter to see what’s what.

Here’s the summary:

o Zwift-calibrated with latest firmware: 2000 watts. I’m sure this is wrong.

o Pre-calibrated, with factory settings on brand-new trainer: 398 FTP. I believe that this is wrong also.

o Keiser stationary bike, hour-long maximum effort: 300 to 330 watts average, depending on how I felt. This was pretty consistent across a couple of bikes I would use. But it might be wrong also. I have no insight into the maintenance those bikes did or did not receive.

o Rouvy-calibrated, with latest firmware: Spin-downs are 7.8 to 8.8 seconds. Zwift FTP test is 275. Maybe this is finally something real. Or maybe this is still wrong.

Right now I’m just frustrated. Perhaps I’ll get that power meter.


(Kristopher Barr) #43

I recently have had an issue with my cycleops Hammer since the firmware update in January.

I’ve calibrated from zwift since they updated their software for cycleops as well.

I was doing a custom workout where I did 7 intervals of around 340 watts with a cadence of 55-60… 5min on, 5 min then at 195 watts, repeat.  When I got to the 6th interval, 3 min in, the resistance dropped to about 150 watts (was like being on a flat with ERG mode disengaged).  The only way to fix was to unplug and reconnect, then find a way to bring my watts back up to re-engage ERG.  It then did the same thing on my final 340 watt interval.  

I tried the Zwift calibration, and it failed.  At the end of the ride, I saved, rebooted Zwift on my mac, then was able to calibrate.

At no point did I get any warning lights on the trainer (apparently there is an overheat light combination).  No overheating smells as referred to sometimes in other threads I’ve read for different trainers.

The room I was in was 22 degrees (if that makes a difference).

I had the trainer overheat on a bkool Alpe D’Huez ride where I spent 26 min at 65 cad and 300 watts.  Cycleops told me to put a fan on the trainer as there was insufficient speed to cool the trainer.  I don’t see this as being the same issue due to the reduced duration and rest intervals.

Has anyone had this type of issue or advice to correct the problem?  It is super frustrating to be doing the intervals and not able to complete them because of equipment failure rather than leg failure.    


(Martin Matejsek) #44

FYI, regarding overheat. I have not had that problem but I do generally run ERG in the big ring up front and about 3-4 gears from smallest in back which spins the trainer pretty fast. This higher trainer RPM can lead to power creep at very low power. For example 140W is about the minimum.

I also have been sticking to my set it and forget it calibration since about November and not having any consistency problems. I just leave my bike on the trainer at all times and maintain rear tire pressure every few days.

Before buying a power meter you might read up on that, there are also issues with some power meters in using ERG so it’s not necessarily a solution either. Also some dual meters like powertap P1s can only read one side, etc.

I still do not trust watt accuracy at all but repeatability seems fine with care.

I think my numbers are probably reading high due to a zwift calibration error.

I do also have occasional o power dropouts that require trainer rebooting but that seems better after going back to my wahoo cadence sensor and disconnecting the magus cadence.

Not sure if the issues are cycleops or zwift, but I personally don’t trust the 5% accuracy claim at all. I wouldn’t be surprised if the average magus user has 50% accuracy error due to this calibration problem. You have the default calibration which may be in wrror as it is not tuned for the bike wheel losses. You have Zwift calibration which works sometimes and mostly not and usually reads higher numbers. You have rouvy calibration which reads lower but almost seems too low.

I’m guessing 50% error…:). Try them all and pick which one motivates you the most to keeping pedaling!! Just don’t be surprised come summer if you buy a power meter that you’re way off.

I do think set it and forget it is best though. As long as your FTP setting is correct to allow workouts to be hard but not too hard, all is well…:slight_smile:


(David Griscom YCW) #45

I never use Zwift to calibrate my Magnus (because of all the issues people have reported).  Using the calibration feature in Rouvy and comparing with my PowerTap wheel I would say the Magnus accuracy is a bit more than 5% but not by much.  I see the largest discrepancy on lower power values where the Magnus reads high.  With power above 250w, my Magnus reads a bit lower than the PowerTap.  It not a big enough deal for me to worry about


(Art M NCC) #46

Re. kickr snap, perhaps other trainers. I don’t think there is a solution to accurate power unless you have a true power meter.

Whether you do calibration in the native software or in zwift, it may/will skew your data.

I’m training by watts, race and do workouts on zwift, the consistency of this figure is very important to me to track progress.

One thing I found that works for me (when training by watts) is that you calibrate your trainer and leave it. Whether those watts are true or not, is not that important, but you will see where your fitness is going.

For the kickr snap, I do the following procedure to ensure some consistency:
Calibration (do once and forget):

  1. Use same tyre every time (I use Vittoria training tyre, just FYI).
  2. Pump tyre to recommended pressure, say 100psi. 
  3. Spin for 10 minutes or so, you basically want to get the turbo and the tyre warmed up.
  4. In wahoo app, do a simple spin down and ensure the app reports between 10 and 15 seconds (as per manual, very very important!). Adjust the knob as needed. Note amount of turns you do. Mark if needed.
  5. Do advanced spin down and you’re good to go.

Before the session:

  1. Always pump your tyre to same pressure you used for calibration, e.g. 100psi
  2. Turn the knob same amount as per calibration (I have a mark on mine. Just fyi it is 1 3/4 turns in my case). You can also do simple spin down for more accuracy. Don’t do advanced spin down anymore.
  3. Enjoy the workout.

You’ll be getting consistent power readings from session to session.


(Mike Hare) #47

I’m pretty sure I have a major problem when an issue is called “resolved” when the resolution is stop using the spindown, use someone else’s app and we’ll get back to you if we ever figure it out. Seems to me CycleOps is a made in USA, long time manufacturers, one of the first actually, that Zwift just had a BIG push to get users to buy a Magnus or Hammer and the fact that calibration does not work and is necessary to get anything out of a workout is a huge surprise…


(Lance McElhaney) #48

Two days ago I did a Zwift race and averaged 231 watts for just under an hour with my Magnus trainer. Yesterday I averaged 174 for an hour riding up Alpe d’Huez on Rouvy.  I did not recalibrate my trainer between rides.   Same tire pressure, trainer wheel tension, and room temperature.  After reading all these posts, I have no clue as to why there is such a big difference when both apps are using the same power reading from the same trainer with the same environmental conditions.  I believe Zwift is way too high, as there is no way I can produce 3.7 w/kg for an hour.


(Mike Hare) #49

I have been back and forth with Zwift about this and my Magnus for several weeks. Most recent reply is they have duplicated the roll down error with the Magnus and to use Rouvy to calibrate until they get it fixed. FWIW, I discovered if Rouvy is paired with anything except the Magnus the calibrating is crazy off target. Even a separate cadence sensor caused problems. Calibrated with Rouvy and only the trainer paired it worked and my readings now make historic sense.