Calibration ruining everything!!


(Chuck Knox) #1

I made the biggest mistake all week by trying to use Zwift’s calibration feature. DO NOT USE THIS!!! When I hop on the bike I’m apparently putting out >300 watts with no effort at all and there’s no way to reset it!

I’m using a cycleops magnus. It’s been working fine for months. I submitted a ticket but I seriously doubt I’m going to get any help in a timely fashion. Now I’m just sitting here frustrated burning time when I should be doing my workout. How frustrating!


(Chuck Knox) #2

 And attempting to calibrate again just yields a timeout error.


(Jon Mayfield) #3

Hi Chuck, sorry for the trouble.   What Zwift does is ask the cycleops trainer to initiate it’s spindown, and the rest is entirely within the trainer. Zwift doesn’t actually do any calibration itself, so I’m not sure how we could have messed anything up there.

One thing to try would be to get the “powertap” app from the iOS app store or Google play store. This will let you verify you have the latest firmware from cycleops, and also try a spindown from within their app.

If the issue continues to happen with Zwift we can see if we can reproduce the issue here and we’ll contact cycleops.  We have a few magnus trainers and spindown worked well in our testing on those units, so your issues are a bit of a surprise.  


(Chuck Knox) #4

I appreciate the feedback. I’ll look into that. I had to uninstall Zwift and reinstall it in order to get rid of the inaccurate power readings, so I’m convinced Zwift is still partly at fault here for not allowing an easy way to scrap calibration numbers.


(Nigel Doyle) #5

Working fine with my Cycleops Hammer trainer. However if I have my 4iiii crank based power meter selected as the power source I get the spanner icon and it’s offering me a spindown where the speed to get to is 32km/h rather than the 37 km/h for the Hammer. The 4iiii only requires a zero offset to be done.


(Staci Solin) #6

Same problem of Cycleops hammer failing calibration in Swift, stopping at 2 mph. Passes calibration in Rouvy. I installed the latest firmware, reinstalled Swift. Same problem persists. Worthless. Glad I’ve spent hundreds on Swift and 1200 on a smart trainer for Swift to break it on a whim.
It’s a calibration software problem only, because when I stop pedaling on a ride, I don’t continue at 2 mph forever… my character STOPS at 0 mph.


(Staci Solin) #7

Zwift auto corrects to Swift…


(Jon Mayfield) #8

Turns out the Hammer is something we don’t quite support for spindown and it was incorrectly showing the spindown button.  This is fixed in our next update (as in, we hide the button. We’re working on getting the proprietary spindown implemented for Cycleops trainers now).

Additionally we fixed a bug where doing a spindown could mess up the ‘road feel’ of the Zwift session that immediately follows, and that too will go live hopefully this week.

Sorry for the trouble!


(Bill Simon) #9

Since calibration I can’t get above 100 w on my Yahoo Kickr. Have recalibrate twice with no luck. What was once enjoyable is now close to unbearable


(Jon Mayfield) #10

Hi Bill, did it work better after you upgraded the iOS app?   


(Chris Popovic) #11

Here’s a dumb question. How the hell do you calibrate your trainer using Zwift. Or for that matter, using Rouvy or Powertap? I’d expect there to be a big, fat “CALIBRATE” button someplace even remotely obvious but I can’t find anything. Searched Google, Youtbue, Cycleops Forums and here and can’t find a simple step-by-step. Is there one out there? 

From what I’ve read on Cycleops, “Hot Calibration” happens via the Rouvy app after you’ve warmed up. Apparently it will ‘pop-up’ when ready. That doesn’t do me any good with Zwift though.


(Derek Rush [RaceWBR]) #12

No, Chris, they don’t make it easy, that’s for sure. On the Rouvy app that I downloaded for my laptop, I click on Free Ride, and then over to the right (after you’ve selected your trainer and other devices) you’ll find a Calibrate Trainer button. I think it’s green. I’ve heard about the Hot Calibration as well, but there doesn’t appear to be any way to initiate that other than riding the trainer yourself for ten minutes beforehand. I wonder if that could also be messing up calibration numbers; perhaps when you do the calibration after warming up on your own, the Rouvy app is calibrating for a cold tire. Like I said, they don’t make it easy.


(Burst Believer) #13

I am really p.o.'d that I’m having the same problem with Zwift and my Magnus trainer after updating the Zwift app – the trainer and ERG functions worked fine until i hit the darned calibrate button. I’ve deleted the zwift app - reinstalled it on my iPad and same problem - I spin easily and register 300 watts!!! someone give me a clue here please!!!


(Derek Rush [RaceWBR]) #14

BB, I can’t even use the ERG mode any longer after I did the Zwift calibration. While I have a FTP of 326, I can hardly hold 300 w in a ERG workout for longer than a couple minutes. Its the same on a free ride workout where it’s supposed to simulate flat terrain; it feels more like I’m riding up a 3 or 4% grade. What I’m doing now is knocking the resistance level in-game down to 25% or even zero. Then, much like a dumb trainer, I just use my gears to get up the watts. It’s pretty pathetic.


(Nigel Doyle) #15

So just do the spindown via the Rouvy application. It’s free. BTW on a Cycleops Hammer I find 100% difficulty makes the hills harder than the same gradient in real life. 50% works well and allows you put out some power going down hill, essential when racing.


(Burst Believer) #16

Okay, will try that - called cycle ops and they said the same thing. Apparently the zwift code funks up the trainer - just saw a new zwift update today so maybe…


(Burst Believer) #17

Nope. Same issues. No pedal resistance even though zwift app reads workout power goals - changing cadence in same gearing increases power readout but not trainer resistance. I’ve calibrated with Rouvy and PowerTap. Have loaded all firmware updates. Have deleted and reinstalled zwift - all to no avail. C’mon Jon mayfield - there’s gotta be some cause from zwift


(Rich Kelley) #18

I am having the same problem with my Tacx Vortex and I’ve wasted the better part of a day trying to troubleshoot this foolishness. Everything was working done until I updated my Zwift software. I agree with the first poster: what was once enjoyable has become infuriating!! I’m about ready to cancel Zwift and try signing up for Trainer Road. This sucks!!!


(Jason K) #19

As a note to all our CycleOps users - I’ve added a known issue article to our knowledge base you can watch for updates on this issue, as well as a link to the Rouvy article explaining how to calibrate in their software.

@Rich: I looked up your account, and the issue you’re experiencing is a different one related to legacy protocols vs FE-C; simply pair Tacx Vortex for both Power and Controllable Trainer, and it’ll solve your resistance problems.


(Jens Huelsermann) #20

This is really frustrating. Same issue here with the Magnus. Everything fine for two months until I hit the calibration button today.

Zwift reply is “we’re working on this”. WHY do you even still offer this calibration button when you know it potentially messes the trainer up??? You know what trainer I’m using. I’m grounded now I guess, thank you!