Cadence keeps dropping to zero - Neo TacX


(Brett Goulder) #1

Hi,

For some reason, cadence keeps dropping to zero, however power remains normal.  I have a TacX Neo to measure power, cadence, etc…  I am using Bluetooth LE, through my Macbook Pro, to connect to Zwift. 

For what it’s worth, I do not have the same issue with TrainerRoad, it seems localized to just when I use Zwift.

To ensure it’s not a signal issue, I placed my Macbook directly next to my TacX, it showed it had the maximum number of bars for connectivity, yet it still kept dropping. Any ideas what the issue might be?  Am I better off with using Ant+? Do I need to get a separate cadence sensor?

Best regards,

Brett


(Brett Goulder) #2

It shows my TacX Neo has a -55dBm signal going to be my computer which is quite good. I am also on the latest firmware on the Neo if this helps at all.


(Jason K) #3

There’s a known issue with Tacx smart trainers where the cadence may occasionally drop to 0. This is supposed to be fixed in the newest (or upcoming) firmware update for your trainer, so I’d recommend contacting Tacx for recommendations on what do to next.


(Chris Newman) #4

Same issue here. Updated to the new firmware etc no change.

Was assuming it was a Bluetooth issue and was going to purchase a dongle to see if that helped.


(Brett Goulder) #5

Found the official answer from TacX here: https://www.facebook.com/groups/TacxNeoOwners/permalink/2172884856272174/ . The latest firmware apparently broke Macbook + Bluetooth + Zwift.  They’re working with the Zwift team to address this issue.  In the meanwhile, I’ll just use my iPad. Hope this helps someone!


(Carlos Mono) #6

With my Tacx Bushido is happening the same =(


(Brett Goulder) #7

@Carlos Apparently it was fixed in today’s Zwift update.  Update your Zwift client and check it out.


(Sykkel-Tony BOC-Medlem) #8

This has nothing to do with MacBook. I have a Tacx Flow and the cadence works as expected in both Tacx utility and Zwift on my iPad mini, but in Zwift I have had to sessions where the cadence was zero the whole ride (about an hours each) except for a few micro seconds. The other rides the cadence has worked perfectly. The trainer and the iPad has been positioned in exactly the same way relative to each other each time, and since both power (Watts) and speed seems to be ok, the problem can not be bluetooth. (What I have noticed though, is that I can not have the Tacx utility app and Zwift active simultaneously, That will mess up the bluetooth connection all together.) 


(Carlos Mono) #9

@Ompa Kaiizer I always close the Tacx Utility App… this week I rode three sessions and Zwift made me that only on the first one… Everything was going great until the last 15 minutes… I really don’t know if it is a Tacx problem or something strange is happening with Zwift… the good thing is that I can control the cadence with my Garmin :slight_smile:


(Steven Horniak) #10

Same thing happened to me today. Cadence was working OK and then dropped to zero. I wasn’t able to get it gong again.


(Claude Biron) #11

This happened to me today on the new London Zwift course.  Taxc and all software updated, and has worked with same software for many rides, up until today!?  I wouldn’t say cadence goes to zero, but rather, the cadence connection drops off (i.e. no cadence sensing).  I have an ANT+ dongle on my MacBook.


(Johnny Enemark) #12

I just started having the same problem with my Bushido Apple TV combo. Cadence drops randomly. It can make for a rather horrific Erg workout session. Does it have something to do with running the companion app? This morning I didn’t launch the companion app and it seemed to work just fine.


(Michael Weiler) #13

I’ve been experiencing this issue as well - with a a iPad. Only seems to occur if my cadence Drops below 55, and particularly below 50 (as on the 17% grade… Or sudden increases in gradient that cause my cadence to drop).

Once the cadence is at that level, it will drop off to 0 and my Avatar will stop pedaling every couple of seconds.  

When I push the cadence back up above 55, The problem goes away.  System displays a pretty consistent power reading, but that may be because I have power smoothing turned on.

Issue is not course specific.