[Bug] Do NOT enable Bluetooth support on mobile device unless explicitly told to do so!


(... david (aka "setuid")) #1

With the new version of Zwift Mobile Link (on Android at least), the ZML app _turns on _the device’s Bluetooth protocol support when ZML is launched either before or during the Zwift desktop application login process at the pairing screen.

Please do not enable Bluetooth unless explicitly permitted to do so!

My Zwift PC has the Bluetooth adapter _physically disabled _and the Zwift application still tries to search for BTLE supported devices during initial pairing, despite not having any Bluetooth support from the PC at all. 

Likewise, the phone itself silently turns on Bluetooth and presumably tries to find devices as well, which also then finds (and pairs itself to) my headset, my laptop and my iPad, because they are in the same Bluetooth profile.

Don’t do that. 

Two important requests: 

  1. Please add a slider/toggle in the ZML “Settings” to enable Bluetooth, something like “Allow Zwift to turn on Bluetooth? [y/N]”, with it _disabled _by default (opt-in, _not _opt-out), and…
  2. If the host OS on the desktop has no Bluetooth support, don’t offer to try to find Bluetooth devices, and hence don’t tell ZML to start looking for them either. 

Because of this gap, I’ve had to forcibly prohibit Zwift Mobile Link from enabling Bluetooth on its own, silently, to avoid greater problems. 

Not all Bluetooth stacks are made the same, and not everyone wants Bluetooth on for no reason. 

Lastly, exiting Zwift Mobile Link, by closing the app or by logging out, does not return the phone’s state to the same way it was when it was launched, it leaves Bluetooth enabled, which is both a possible attack vector (Bluesnarf, etc.), but also a major battery drain. Many people keep BT disabled for this latter reason. 

This most-recent version of Zwift Mobile Link drains the battery 4x faster than previous releases (even with Bluetooth disabled). My phone went from 45% battery to 1% battery in 90 minutes while running during tonight’s TGIF ride. 73.7% of the remaining battery was consumed by Zwift during that time period.

If you enable Bluetooth during the same timeframe, the phone wouldn’t last 45 minutes without completely draining to nothing. EEK! 

You can see the significant drop here: 

I would consider this a “Grave” bug that needs immediate attention. 


(Lukman Ascenders PTz (A)) #2

Expedite this!


(John Scott) #3

Same problem here. Drained my phone (Galaxy S5) from 100% to 0 in under 3 hours. When plugged, charge rate was barely above drain rate.


(Michael Henasey) #4

is this an Android only issue? 

Bluetooth LE isn’t enabled by default on my iPhone.


(... david (aka "setuid")) #5

Auto-enabling Bluetooth on the device seems to be an Android-specific issue, but as others are reporting in Facebook, 100% of the responders (Android and iOS) are reporting significant battery drain with the most-recent release of ZML.

https://www.facebook.com/groups/zwiftriders/permalink/458392024367108/


(Michael Henasey) #6

@David

is this battery drain specific to BT LE or just the ZML?


(... david (aka "setuid")) #7

Excessive drain is ZML, but the added feature of silently enabling Bluetooth on the device causes that drain to double or treble in speed.

Without BT enabled on my device, my batter went from 45% to 0% in a single 90-minute TGIF ride. If I had done that with BT enabled, it would have drained in 30-45 minutes.


(Michael Henasey) #8

@David

ok, thanks for the info. i’ll keep an eye on things. i’ve been using either an iPhone 6 or iPad mini for Zwift and I don’t have BT LE enabled but I can’t say I"ve seen any significant battery drain on multi hour rides lately. I also stream Apple music and either listen with headphones or have BT connected to my desktop running Zwift which has 2.1 speakers connected.